CVE-2004-1899
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:02:35
NMCO    

[原文]The administration interface in Monit 1.4 through 4.2 allows remote attackers to cause an off-by-one overflow via a POST that contains 1024 bytes.


[CNNVD]多个Monit管理界面远程漏洞(CNNVD-200412-494)

        Monit 1.4至4.2版本的管理界面存在漏洞。远程攻击者借助包含1024个字节的POST导致off-by-one溢出。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:tildeslash:monit:1.4
cpe:/a:tildeslash:monit:3.2
cpe:/a:tildeslash:monit:4.1
cpe:/a:tildeslash:monit:3.1
cpe:/a:tildeslash:monit:4.0
cpe:/a:tildeslash:monit:3.0
cpe:/a:tildeslash:monit:4.2
cpe:/a:tildeslash:monit:4.1.1
cpe:/a:tildeslash:monit:4.3_beta_2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1899
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1899
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-494
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108119149103696&w=2
(UNKNOWN)  BUGTRAQ  20040405 Advisory: Multiple Vulnerabilities in Monit
http://www.securityfocus.com/bid/10051
(PATCH)  BID  10051
http://xforce.iss.net/xforce/xfdb/15736
(UNKNOWN)  XF  monit-post-offbyone-bo(15736)

- 漏洞信息

多个Monit管理界面远程漏洞
中危 缓冲区溢出
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Monit 1.4至4.2版本的管理界面存在漏洞。远程攻击者借助包含1024个字节的POST导致off-by-one溢出。

- 公告与补丁

        Netwosix Linux has released advisory LNSA-#2004-0008 and fixes for the off-by-one error and the stack overflow in the authentication functionality. Please see the attached advisory for more information.
        Gentoo has released updates to address this issue, which may be applied with the following commands:
        emerge sync
        emerge -pv ">=app-admin/monit-4.2.1"
        emerge ">=app-admin/monit-4.2.1"
        The vendor has released fixes to address these issues:
        TildeSlash Monit 3.0
        
        TildeSlash Monit 3.1
        
        TildeSlash Monit 3.2
        
        TildeSlash Monit 4.0
        
        TildeSlash Monit 4.1
        
        TildeSlash Monit 4.1.1
        
        TildeSlash Monit 4.2
        
        TildeSlash Monit 4.3 Beta 2
        

- 漏洞信息

4979
Monit POST Input Off-By-One DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

Tildeslash Technology's Monit contains a flaw that may allow a remote denial of service. The issue is triggered when the HTTP Server recieves a POST submission of a specific size, and will result in loss of availability for the service.

- 时间线

2004-04-05 2004-04-04
2004-04-05 Unknow

- 解决方案

Upgrade to version 4.2.1 Stable or higher, or 4.3 Beta 3 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround(s): disable the Monit HTTP interface.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站