CVE-2004-1896
CVSS7.6
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:02:31
NMCO    

[原文]Heap-based buffer overflow in in_mod.dll in Nullsoft Winamp 2.91 through 5.02 allows remote attackers to execute arbitrary code via a Fasttracker 2 (.xm) mod media file.


[CNNVD]NullSoft Winamp in_mod.dll 插件程序堆溢出漏洞(CNNVD-200412-951)

        Nullsoft Winamp 2.91版本到5.02版本的in_mod.dll存在基于堆的缓冲区溢出漏洞。远程攻击者可以借助Fasttracker 2 (.xm)模块媒体文件执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.6 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:nullsoft:winamp:5.0.2
cpe:/a:nullsoft:winamp:5.0.1
cpe:/a:nullsoft:winamp:2.91Nullsoft Winamp 2.91
cpe:/a:nullsoft:winamp:3.0
cpe:/a:nullsoft:winamp:3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1896
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1896
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-951
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108118289208693&w=2
(UNKNOWN)  BUGTRAQ  20040405 NGSSoftware Insight Security Research Advisory
http://securitytracker.com/id?1009660
(UNKNOWN)  SECTRACK  1009660
http://www.nextgenss.com/advisories/winampheap.txt
(PATCH)  MISC  http://www.nextgenss.com/advisories/winampheap.txt
http://www.securityfocus.com/bid/10045
(PATCH)  BID  10045
http://xforce.iss.net/xforce/xfdb/15727
(UNKNOWN)  XF  winamp-inmod-bo(15727)

- 漏洞信息

NullSoft Winamp in_mod.dll 插件程序堆溢出漏洞
高危 缓冲区溢出
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Nullsoft Winamp 2.91版本到5.02版本的in_mod.dll存在基于堆的缓冲区溢出漏洞。远程攻击者可以借助Fasttracker 2 (.xm)模块媒体文件执行任意代码。

- 公告与补丁

        Nullsoft has released Winamp 5.03 to address this issue.
        NullSoft Winamp 2.91
        
        NullSoft Winamp 3.0
        
        NullSoft Winamp 3.1
        
        NullSoft Winamp 5.0 1
        
        NullSoft Winamp 5.0 2
        

- 漏洞信息

4944
Winamp Fasttracker 2 Plug-In in_mod.dll Overflow
Local Access Required, Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

An overflow exists in Nullsoft WinAmp. WinAmp fails to perform a proper boundary check within the in_mod.dll plugin when loading Fasktrackker 2 (".xm") media files resulting in a heap-based buffer overflow. With a specially crafted request, an attacker can cause execution of arbitrary code resulting in a loss of integrity.

- 时间线

2004-04-05 2004-02-20
2001-04-01 Unknow

- 解决方案

Upgrade to version 5.03 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: Disable support for Fasttracker 2 media files

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站