CVE-2004-1893
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:02:28
NMCO    

[原文]Dreamweaver MX, when "Using Driver On Testing Server" or "Using DSN on Testing Server" is selected, uploads the mmhttpdb.asp script to the web site but does not require authentication, which allows remote attackers to obtain sensitive information and possibly execute arbitrary SQL commands via a direct request to mmhttpdb.asp.


[CNNVD]Macromedia Dreamweaver远程用户数据库访问漏洞(CNNVD-200412-974)

        
        Dreamweaver是Macromedia公司开发和维护的一款流行的网页设计软件,可使用在Microsoft Windows操作系统下。
        Dreamweaver远程数据库连接功能存在安全问题,远程攻击者可以利用这个漏洞访问数据库获得敏感信息。
        Dreamweaver的远程数据库连接功能为了用于动态数据库驱动而安装的脚本存在问题,攻击者可以使用这些脚本发送SQL命令给服务程序,获得数据库服务器的控制权。
        当用户在数据库连接对话框中指定"Using Driver On Testing Server"或
        "Using DSN on Testing Server",Dreamweaver自动上传文件到测试服务器允许Dreamweaver通过HTTP协议操作远程数据库,这允许Dreamweaver获得数据库信息来帮助用户建立在站点,但是这个文件可获得系统中定义的DSN信息,如果DSN和数据库没有密码保护,该可以发送SQL命令给数据库而获得敏感信息。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1893
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1893
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-974
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108102481929451&w=2
(UNKNOWN)  BUGTRAQ  20040403 [securityzone@macromedia.com: New Macromedia Security Zone Bulletin Posted]
http://www.macromedia.com/devnet/security/security_zone/mpsb04-05.html
(VENDOR_ADVISORY)  CONFIRM  http://www.macromedia.com/devnet/security/security_zone/mpsb04-05.html
http://www.nextgenss.com/advisories/dreamweaver.txt
(UNKNOWN)  MISC  http://www.nextgenss.com/advisories/dreamweaver.txt
http://www.securityfocus.com/bid/10036
(UNKNOWN)  BID  10036
http://xforce.iss.net/xforce/xfdb/15721
(UNKNOWN)  XF  dreamweaver-test-script-sql-injection(15721)

- 漏洞信息

Macromedia Dreamweaver远程用户数据库访问漏洞
中危 配置错误
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Dreamweaver是Macromedia公司开发和维护的一款流行的网页设计软件,可使用在Microsoft Windows操作系统下。
        Dreamweaver远程数据库连接功能存在安全问题,远程攻击者可以利用这个漏洞访问数据库获得敏感信息。
        Dreamweaver的远程数据库连接功能为了用于动态数据库驱动而安装的脚本存在问题,攻击者可以使用这些脚本发送SQL命令给服务程序,获得数据库服务器的控制权。
        当用户在数据库连接对话框中指定"Using Driver On Testing Server"或
        "Using DSN on Testing Server",Dreamweaver自动上传文件到测试服务器允许Dreamweaver通过HTTP协议操作远程数据库,这允许Dreamweaver获得数据库信息来帮助用户建立在站点,但是这个文件可获得系统中定义的DSN信息,如果DSN和数据库没有密码保护,该可以发送SQL命令给数据库而获得敏感信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 客户不要在可对外访问的测试服务器上定义数据库连接,为了防止数据库未授权访问,必须进行密码保护,如果数据连接已经定义,使用Dreamweaver的删除连接脚本菜单命令删除文件。
        厂商补丁:
        Macromedia
        ----------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.macromedia.com/

- 漏洞信息

4943
Macromedia Dreamweaver Database Connection Script mmhttpdb.asp Remote Privilege Escalation
Remote / Network Access
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2004-04-05 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站