CVE-2004-1889
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:42:37
NMCO    

[原文]Unknown vulnerability in ftpd in SGI IRIX 6.5.20 through 6.5.23 allows remote attackers to cause a denial of service (hang) via a link failure with Microsoft Windows.


[CNNVD]SGI IRIX ftpd多个远程拒绝服务漏洞(CNNVD-200412-930)

        
        IRIX是一款由SGI公司开发和维护的商业性质UNIX操作系统。
        SGI IRIX包含的FTP服务程序存在多个问题,远程攻击者可使FTP服务程序崩溃。
        第一问题未知涉及到IRIX FTPD进程在当与Microsoft Windows 2000连接时会由于连接失败而产生不确定的挂起。
        第二个问题未知在处理PORT模式上,可造成拒绝服务。
        第三个问题未知ftp_syslog()函数在匿名FTP方式下存在问题,可造成拒绝服务。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sgi:irix:6.5.23SGI IRIX 6.5.23
cpe:/o:sgi:irix:6.5.21SGI IRIX 6.5.21
cpe:/o:sgi:irix:6.5.22SGI IRIX 6.5.22
cpe:/o:sgi:irix:6.5.20mSGI IRIX 6.5.20m
cpe:/o:sgi:irix:6.5.21mSGI IRIX 6.5.21m
cpe:/o:sgi:irix:6.5.21fSGI IRIX 6.5.21f
cpe:/o:sgi:irix:6.5.20fSGI IRIX 6.5.20f
cpe:/o:sgi:irix:6.5.20SGI IRIX 6.5.20

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1889
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1889
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-930
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/15722
(UNKNOWN)  XF  irix-ftpd-link-dos(15722)
http://www.securityfocus.com/bid/10037
(UNKNOWN)  BID  10037
ftp://patches.sgi.com/support/free/security/advisories/20040401-01-P.asc
(UNKNOWN)  SGI  20040401-01-P

- 漏洞信息

SGI IRIX ftpd多个远程拒绝服务漏洞
中危 未知
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        IRIX是一款由SGI公司开发和维护的商业性质UNIX操作系统。
        SGI IRIX包含的FTP服务程序存在多个问题,远程攻击者可使FTP服务程序崩溃。
        第一问题未知涉及到IRIX FTPD进程在当与Microsoft Windows 2000连接时会由于连接失败而产生不确定的挂起。
        第二个问题未知在处理PORT模式上,可造成拒绝服务。
        第三个问题未知ftp_syslog()函数在匿名FTP方式下存在问题,可造成拒绝服务。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        SGI
        ---
        SGI已经为此发布了一个安全公告(20040401-01-P)以及相应补丁:
        20040401-01-P:IRIX ftpd ftp_syslog issue with anonymous FTP
        链接:ftp://patches.sgi.com/support/free/security/advisories/20040401-01-P
        补丁情况:
         系统版本 未知否受影响 补丁号 备注
         ---------- ----------- ------- -------------
         IRIX 3.x 未知 备注 1
         IRIX 4.x 未知 备注 1
         IRIX 5.x 未知 备注 1
         IRIX 6.0.x 未知 备注 1
         IRIX 6.1 未知 备注 1
         IRIX 6.2 未知 备注 1
         IRIX 6.3 未知 备注 1
         IRIX 6.4 未知 备注 1
         IRIX 6.5 未知 备注 1
         IRIX 6.5.1 未知 备注 1
         IRIX 6.5.2 未知 备注 1
         IRIX 6.5.3 未知 备注 1
         IRIX 6.5.4 未知 备注 1
         IRIX 6.5.5 未知 备注 1
         IRIX 6.5.6 未知 备注 1
         IRIX 6.5.7 未知 备注 1
         IRIX 6.5.8 未知 备注 1
         IRIX 6.5.9 未知 备注 1
         IRIX 6.5.10 未知 备注 1
         IRIX 6.5.11 未知 备注 1
         IRIX 6.5.12 未知 备注 1
         IRIX 6.5.13 未知 备注 1
         IRIX 6.5.14 未知 备注 1
         IRIX 6.5.15 未知 备注 1
         IRIX 6.5.16 未知 备注 1
         IRIX 6.5.17 未知 备注 1
         IRIX 6.5.18 未知 备注 1
         IRIX 6.5.19 未知 备注 1
         IRIX 6.5.20 是 5547 备注 2 & 3
         IRIX 6.5.21 是 5447 备注 2 & 3
         IRIX 6.5.22 是 5447 备注 2 & 3
         IRIX 6.5.23 是 5447 备注 2 & 3
        备注:
        
        1) 这个版本的IRIX系统已经不再被维护了,请升级到受支持的版本,参看
        
        http://support.sgi.com来获得更多的信息。

        2) 如果你还未收到一张IRIX 6.5.x for IRIX 6.5的CD,请联系SGI的支持部门,或访问:
        http://support.sgi.com

        3) 安装补丁。
        补丁文件校验如下:
        Filename: README.patch.5525
        Algorithm #1 (sum -r): 06398 8 README.patch.5525
        Algorithm #2

- 漏洞信息

16895
IRIX ftpd Unspecified Windows Link DoS
Remote / Network Access Denial of Service
Loss of Availability

- 漏洞描述

IRIX contains a flaw that may allow a remote denial of service. The issue is triggered when ftpd link failure occurs during a connection to a Microsoft Windows system, and will result in loss of availability for the service. No further details are available.

- 时间线

2004-04-01 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 6.5.23 or higher after the correction date, as it has been reported to fix this vulnerability. In addition, Silicon Graphics, Inc. has released patches for some older versions.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站