CVE-2004-1870
CVSS7.5
发布时间 :2004-03-29 00:00:00
修订时间 :2016-10-17 23:02:05
NMCOE    

[原文]Multiple SQL injection vulnerabilities in PhotoPost PHP Pro 4.6.x and earlier allow remote attackers to gain users' passwords via the (1) photo parameter to addfav.php, (2) photo parameter to comments.php, (3) credit parameter to comments.php, (4) cat parameter to index.php, (5) ppuser parameter to showgallery.php, (6) cat parameter to showgallery.php, (7) cat parameter to uploadphoto.php, (8) albumid parameter to useralbums.php, or (9) albumid parameter to useralbums.php.


[CNNVD]All Enthusiast Photopost PHP Pro多个输入验证漏洞(CNNVD-200403-122)

        PhotoPost PHP Pro 4.6.x以及之前的版本存在多个SQL注入漏洞。远程攻击者借助(1)addfav.php的photo参数,(2)comments.php的photo参数,(3)comments.php的credit参数,(4)index.php的cat漏洞,(5)showgallery.php的ppuser漏洞,(6)showgallery.php的cat参数,(7)uploadphoto.php的cat参数,(8)useralbums.php的albumid参数获得用户的密码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:photopost:photopost_php_pro:3.3
cpe:/a:photopost:photopost_php_pro:4.6
cpe:/a:photopost:photopost_php_pro:3.1
cpe:/a:photopost:photopost_php_pro:4.0
cpe:/a:photopost:photopost_php_pro:4.8.1
cpe:/a:photopost:photopost_php_pro:3.2
cpe:/a:photopost:photopost_php_pro:4.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1870
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1870
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200403-122
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108057790723123&w=2
(UNKNOWN)  BUGTRAQ  20040328 PhotoPost PHP Pro Multiple Vulnerabilities
http://securitytracker.com/id?1009571
(VENDOR_ADVISORY)  SECTRACK  1009571
http://www.securityfocus.com/bid/9994
(VENDOR_ADVISORY)  BID  9994
http://xforce.iss.net/xforce/xfdb/15642
(VENDOR_ADVISORY)  XF  photopost-php-sql-injection(15642)

- 漏洞信息

All Enthusiast Photopost PHP Pro多个输入验证漏洞
高危 SQL注入
2004-03-29 00:00:00 2006-09-27 00:00:00
远程  
        PhotoPost PHP Pro 4.6.x以及之前的版本存在多个SQL注入漏洞。远程攻击者借助(1)addfav.php的photo参数,(2)comments.php的photo参数,(3)comments.php的credit参数,(4)index.php的cat漏洞,(5)showgallery.php的ppuser漏洞,(6)showgallery.php的cat参数,(7)uploadphoto.php的cat参数,(8)useralbums.php的albumid参数获得用户的密码。

- 公告与补丁

        It is reported that PhotoPost PHP Pro 4.86 has been released to address these issues. Please contact the vendor for more information and to obtain the fixed version.

- 漏洞信息 (23885)

PhotoPost PHP Pro 3.x/4.x showgallery.php Multiple Parameter SQL Injection (EDBID:23885)
php webapps
2004-03-29 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/9994/info

Multiple SQL injection, cross-site scripting and HTML injection vulnerabilities have been identified in the application, which may allow an attacker to execute arbitrary HTML or script code in a user's browser and/or influence SQL query logic to disclose sensitive information and carry out other attacks. 

Photopost PHP Pro 4.6.0 and prior may be prone to these issues. Photopost PHP Pro 4.8.1 is reported vulnerable to these issues as well.

http://www.example.com/showgallery.php?ppuser=-2'%20UNION%20SELECT%200,email,
0,0,0,0,0,0%20FROM%20user%20WHERE%20userid='1&cat=500		

- 漏洞信息

10261
PhotoPost PHP Pro comments.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

PhotoPost PHP Pro contains a flaw that will allow a remote attacker to inject arbitrary SQL code. The problem is that multiple variables in the 'comments.php' script are not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-03-28 Unknow
2004-03-28 Unknow

- 解决方案

Upgrade to version 4.86 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站