CVE-2004-1840
CVSS4.3
发布时间 :2004-03-22 00:00:00
修订时间 :2016-10-17 23:01:26
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in MS Analysis module 2.0 for PHP-Nuke allows remote attackers to inject arbitrary web script or HTML via the (1) screen parameter to modules.php, (2) module_name parameter to title.php, (3) sortby parameter to modules.php, or (4) overview parameter to modules.php.


[CNNVD]PHP-Nuke MS-Analysis Module Multiple跨站脚本攻击漏洞(CNNVD-200403-093)

        PHP-Nuke的MS Analysis module 2.0版本存在Multiple跨站脚本攻击(XSS)漏洞。远程攻击者借助(1)modules.php的screen参数,(2)title.php的module_name参数,(3)modules.php的sortby参数,或(4)modules.php的overview参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:francisco_burzi:php-nuke:7.0
cpe:/a:francisco_burzi:php-nuke:6.6
cpe:/a:francisco_burzi:php-nuke:6.5_rc1
cpe:/a:francisco_burzi:php-nuke:7.0_final
cpe:/a:francisco_burzi:php-nuke:6.5_rc2
cpe:/a:francisco_burzi:php-nuke:6.9
cpe:/a:francisco_burzi:php-nuke:6.5_beta1
cpe:/a:francisco_burzi:php-nuke:6.5_rc3
cpe:/a:francisco_burzi:php-nuke:6.7
cpe:/a:francisco_burzi:php-nuke:6.5
cpe:/a:francisco_burzi:php-nuke:6.5_final

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1840
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1840
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200403-093
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108006319730976&w=2
(UNKNOWN)  BUGTRAQ  20040322 [waraxe-2004-SA#011 Multiple vulnerabilities in MS Analysis v2.0 module for PhpNuke]
http://www.securityfocus.com/bid/9947
(VENDOR_ADVISORY)  BID  9947
http://xforce.iss.net/xforce/xfdb/15575
(VENDOR_ADVISORY)  XF  msanalysis-modules-title-xss(15575)

- 漏洞信息

PHP-Nuke MS-Analysis Module Multiple跨站脚本攻击漏洞
中危 跨站脚本
2004-03-22 00:00:00 2005-10-20 00:00:00
远程  
        PHP-Nuke的MS Analysis module 2.0版本存在Multiple跨站脚本攻击(XSS)漏洞。远程攻击者借助(1)modules.php的screen参数,(2)title.php的module_name参数,(3)modules.php的sortby参数,或(4)modules.php的overview参数注入任意web脚本或HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息

4544
MS Analysis for PHP-Nuke modules.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

MS Analysis contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "screen", "sortby" or "overview" variables upon submission to the modules.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-03-22 Unknow
2004-03-22 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站