CVE-2004-1837
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:01:22
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Mod_survey 3.0.x before 3.0.16-pre2 and 3.2.x before 3.2.0-pre4 allows remote attackers to inject arbitrary web script or HTML via the certain survey fields or error messages for malformed query strings.


[CNNVD]Joel Palmius Mod_Survey调查输入字段HTML注入漏洞(CNNVD-200412-675)

        Mod_survey 3.0.16-pre2之前3.0.x版本和3.2.0-pre4之前3.2.x版本存在漏洞。远程攻击者可以借助某些调查字段或畸形查询字符串中的错误消息,注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:joel_palmius:mod_survey:3.0.9
cpe:/a:joel_palmius:mod_survey:3.2.0_pre3
cpe:/a:joel_palmius:mod_survey:3.2.0_pre1
cpe:/a:joel_palmius:mod_survey:3.2.0_pre2
cpe:/a:joel_palmius:mod_survey:3.0.15
cpe:/a:joel_palmius:mod_survey:3.0.6
cpe:/a:joel_palmius:mod_survey:3.0.12
cpe:/a:joel_palmius:mod_survey:3.0.14e
cpe:/a:joel_palmius:mod_survey:3.0.15_pre2
cpe:/a:joel_palmius:mod_survey:3.0.4
cpe:/a:joel_palmius:mod_survey:3.0.1
cpe:/a:joel_palmius:mod_survey:3.0.10
cpe:/a:joel_palmius:mod_survey:3.0.13
cpe:/a:joel_palmius:mod_survey:3.0.15_pre5
cpe:/a:joel_palmius:mod_survey:3.0.3
cpe:/a:joel_palmius:mod_survey:3.0.11
cpe:/a:joel_palmius:mod_survey:3.0.15_pre3
cpe:/a:joel_palmius:mod_survey:3.0.5
cpe:/a:joel_palmius:mod_survey:3.0.14
cpe:/a:joel_palmius:mod_survey:3.0.15_pre4
cpe:/a:joel_palmius:mod_survey:3.0.2
cpe:/a:joel_palmius:mod_survey:3.0.14d
cpe:/a:joel_palmius:mod_survey:3.0.15_pre1
cpe:/a:joel_palmius:mod_survey:3.0.0
cpe:/a:joel_palmius:mod_survey:3.0.15_pre6
cpe:/a:joel_palmius:mod_survey:3.0.16_pre1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1837
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1837
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-675
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107997967421972&w=2
(UNKNOWN)  BUGTRAQ  20040322 Mod_Survey security advisory: Script injection bug
http://securitytracker.com/id?1009516
(PATCH)  SECTRACK  1009516
http://www.securityfocus.com/bid/9941
(PATCH)  BID  9941
http://xforce.iss.net/xforce/xfdb/15582
(UNKNOWN)  XF  modsurvey-xss(15582)

- 漏洞信息

Joel Palmius Mod_Survey调查输入字段HTML注入漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Mod_survey 3.0.16-pre2之前3.0.x版本和3.2.0-pre4之前3.2.x版本存在漏洞。远程攻击者可以借助某些调查字段或畸形查询字符串中的错误消息,注入任意web脚本或HTML。

- 公告与补丁

        This issue has been addressed in Mod_Survey versions 3.0.16-pre2 (stable branch) and 3.2.0-pre4 (development branch).
        Joel Palmius Mod_Survey 3.0 .0
        
        Joel Palmius Mod_Survey 3.0 .4
        
        Joel Palmius Mod_Survey 3.0 .6
        
        Joel Palmius Mod_Survey 3.0 .2
        
        Joel Palmius Mod_Survey 3.0 .5
        
        Joel Palmius Mod_Survey 3.0 .10
        
        Joel Palmius Mod_Survey 3.0 .1
        
        Joel Palmius Mod_Survey 3.0 .3
        
        Joel Palmius Mod_Survey 3.0.11
        
        Joel Palmius Mod_Survey 3.0.12
        
        Joel Palmius Mod_Survey 3.0.13
        
        Joel Palmius Mod_Survey 3.0.14 d
        
        Joel Palmius Mod_Survey 3.0.14 e
        
        Joel Palmius Mod_Survey 3.0.14
        
        Joel Palmius Mod_Survey 3.0.15 -pre5
        
        Joel Palmius Mod_Survey 3.0.15 -pre6
        
        Joel Palmius Mod_Survey 3.0.15 -pre3
        
        Joel Palmius Mod_Survey 3.0.15 -pre1
        
        Joel Palmius Mod_Survey 3.0.15 -pre2
        
        Joel Palmius Mod_Survey 3.0.15
        
        Joel Palmius Mod_Survey 3.0.15 -pre4
        
        Joel Palmius Mod_Survey 3.0.16 -pre1
        
        Joel Palmius Mod_Survey 3.0.9
        
        Joel Palmius Mod_Survey 3.2 .0-pre3
        
        Joel Palmius Mod_Survey 3.2 .0-pre2
        
        Joel Palmius Mod_Survey 3.2 .0-pre1
        

- 漏洞信息

4563
Mod_Survey ENV XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Mod_survey contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the ENV variable upon submission. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-03-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.0.14e or 3.0.15-pre6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站