CVE-2004-1830
CVSS5.0
发布时间 :2004-03-18 00:00:00
修订时间 :2016-10-17 23:01:14
NMCOE    

[原文]error.php in Error Manager 2.1 for PHP-Nuke 6.0 allows remote attackers to obtain sensitive information via an invalid (1) language, (2) newlang, or (3) lang parameter, which leaks the pathname in a PHP error message.


[CNNVD]PHP-Nuke Error Manager模块多个安全漏洞(CNNVD-200403-086)

        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke包含的错误管理模块存在多个安全问题,远程攻击者可以利用这个漏洞获得敏感路径信息或获得进行验证的敏感信息。
        1)路径泄露问题
        问题存在与error.php文件中,提交任意参数给'newlang',可返回包含应用程序安装路径的敏感信息。
        2)跨站脚本执行攻击
        问题存在与error.php文件中,由于对'pagetitle'和'error'参数缺少充分过滤,提交包含恶意脚本代码数据,当目标用户浏览此连接时,可导致敏感信息泄露。
        3)脚本注入到错误日志中
        Error Manager在记录日志错误时会记录引用,请求URI等信息,但没有对HTML标记进行任何过滤,因此攻击者可以注入热仪脚本代码到错误日志,当管理员查看时,可窃取COOKIE敏感信息,或建立管理员帐户。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1830
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1830
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200403-086
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107963064317560&w=2
(UNKNOWN)  BUGTRAQ  20040318 [waraxe-2004-SA#010 - Multiple vulnerabilities in Error Manager
http://www.securityfocus.com/bid/9911
(UNKNOWN)  BID  9911
http://xforce.iss.net/xforce/xfdb/15524
(UNKNOWN)  XF  errormanager-error-path-disclosure(15524)

- 漏洞信息

PHP-Nuke Error Manager模块多个安全漏洞
中危 未知
2004-03-18 00:00:00 2006-09-22 00:00:00
远程  
        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke包含的错误管理模块存在多个安全问题,远程攻击者可以利用这个漏洞获得敏感路径信息或获得进行验证的敏感信息。
        1)路径泄露问题
        问题存在与error.php文件中,提交任意参数给'newlang',可返回包含应用程序安装路径的敏感信息。
        2)跨站脚本执行攻击
        问题存在与error.php文件中,由于对'pagetitle'和'error'参数缺少充分过滤,提交包含恶意脚本代码数据,当目标用户浏览此连接时,可导致敏感信息泄露。
        3)脚本注入到错误日志中
        Error Manager在记录日志错误时会记录引用,请求URI等信息,但没有对HTML标记进行任何过滤,因此攻击者可以注入热仪脚本代码到错误日志,当管理员查看时,可窃取COOKIE敏感信息,或建立管理员帐户。
        

- 公告与补丁

        厂商补丁:
        Gijza.net
        ---------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.gijza.net

- 漏洞信息 (23844)

PHP-Nuke Error Manager Module 2.1 error.php language Variable Path Disclosure (EDBID:23844)
php webapps
2004-03-18 Verified
0 Janek Vind
N/A [点击下载]
source: http://www.securityfocus.com/bid/9911/info

It has been reported that Error Manager is prone to multiple vulnerabilities. These issues are due to failure to validate user input, failure to handle exceptional conditions and simple design errors.

These issues may be leveraged to carry out cross-site scripting attacks, reveal information about the application configuration and initiate HTML injection attacks against the affected system.

http://www.example.com/nuke71/error.php?newlang=foobar		

- 漏洞信息

4386
PHP-Nuke Error Manager error.php language Variable Path Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

PHP-Nuke Error Manager contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when sending a specially crafted URL request to the 'error.php' script, which will disclose the installation path resulting in a loss of confidentiality.

- 时间线

2004-03-18 Unknow
2004-03-18 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站