发布时间 :2004-03-16 00:00:00
修订时间 :2016-10-17 23:01:08

[原文]Cross-site scripting (XSS) vulnerability in index.php in Mambo Open Source 4.5 stable 1.0.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the (1) return or (2) mos_change_template parameters.

[CNNVD]Mambo Open Source Index.PHP跨站脚本攻击漏洞(CNNVD-200403-083)

        Mambo Open Source 4.5 stable 1.0.3以及以前的版本的index.php存在跨站脚本攻击(XSS)漏洞。远程攻击者借助(1)return或(2)mos_change_template参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040316 Mambo Open Source Multiple Vulnerabilities
(VENDOR_ADVISORY)  XF  mambo-return-moschangetemplate-xss(15499)

- 漏洞信息

Mambo Open Source Index.PHP跨站脚本攻击漏洞
中危 跨站脚本
2004-03-16 00:00:00 2005-10-20 00:00:00
        Mambo Open Source 4.5 stable 1.0.3以及以前的版本的index.php存在跨站脚本攻击(XSS)漏洞。远程攻击者借助(1)return或(2)mos_change_template参数注入任意web脚本或HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (23824)

Mambo Open Source 4.5 index.php Multiple Parameter XSS (EDBID:23824)
php webapps
2004-03-16 Verified
0 JeiAr
N/A [点击下载]

It has been reported that the Mambo 'index.php' script is prone to a cross-site scripting vulnerability. This issue is due to a failure of the application to properly validate user supplied URI input. This issue could permit a remote attacker to create a malicious link to the vulnerable application that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user.[XSS]		

- 漏洞信息

Mambo Open Source index.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public

- 漏洞描述

Mambo Open Source 4.5 contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "return" and ""mos_change_template" variables upon submission to the index.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-03-16 Unknow
2004-03-16 Unknow

- 解决方案

Upgrade to version 1.0.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者