CVE-2004-1822
CVSS4.3
发布时间 :2004-03-15 00:00:00
修订时间 :2016-10-17 23:01:04
NMCOE    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Phorum 3.1 through 5.0.3 beta allow remote attackers to inject arbitrary web script or HTML via the (1) HTTP_REFERER parameter to login.php, (2) HTTP_REFERER parameter to register.php, or (3) target parameter to profile.php.


[CNNVD]Phorum Multiple Module跨站脚本漏洞(CNNVD-200403-055)

        Phorum 3.1到5.0.3测试版存在多个跨站脚本漏洞。远程攻击者借助(1)login.php的HTTP_REFERER参数,(2)register.php的HTTP_REFERER参数,或(3)profile.php的target参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phorum:phorum:3.2.3a
cpe:/a:phorum:phorum:3.3.2a
cpe:/a:phorum:phorum:3.2.3b
cpe:/a:phorum:phorum:3.2.6Phorum 3.2.6
cpe:/a:phorum:phorum:3.4.4Phorum 3.4.4
cpe:/a:phorum:phorum:3.2.5Phorum 3.2.5
cpe:/a:phorum:phorum:3.4.3Phorum 3.4.3
cpe:/a:phorum:phorum:3.1.1_pre
cpe:/a:phorum:phorum:3.2.4Phorum 3.2.4
cpe:/a:phorum:phorum:3.4.2Phorum 3.4.2
cpe:/a:phorum:phorum:3.2.3Phorum 3.2.3
cpe:/a:phorum:phorum:3.3.2Phorum 3.3.2
cpe:/a:phorum:phorum:3.4.1Phorum 3.4.1
cpe:/a:phorum:phorum:3.4Phorum 3.4
cpe:/a:phorum:phorum:3.1Phorum 3.1
cpe:/a:phorum:phorum:3.2Phorum 3.2
cpe:/a:phorum:phorum:3.3.2b3
cpe:/a:phorum:phorum:3.3.1a
cpe:/a:phorum:phorum:3.1.1a
cpe:/a:phorum:phorum:3.2.8Phorum 3.2.8
cpe:/a:phorum:phorum:3.4.6Phorum 3.4.6
cpe:/a:phorum:phorum:3.2.7Phorum 3.2.7
cpe:/a:phorum:phorum:3.4.5Phorum 3.4.5
cpe:/a:phorum:phorum:3.1.1_rc2
cpe:/a:phorum:phorum:3.2.2Phorum 3.2.2
cpe:/a:phorum:phorum:3.3.1Phorum 3.3.1
cpe:/a:phorum:phorum:3.1.2Phorum 3.1.2
cpe:/a:phorum:phorum:3.1.1Phorum 3.1.1
cpe:/a:phorum:phorum:5.0.3_beta

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1822
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1822
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200403-055
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107939479713136&w=2
(UNKNOWN)  BUGTRAQ  20040315 Phorum 5.0.3 Beta && Earlier XSS Issues
http://phorum.org/changelog.txt
(VENDOR_ADVISORY)  CONFIRM  http://phorum.org/changelog.txt
http://securitytracker.com/id?1009433
(UNKNOWN)  SECTRACK  1009433
http://www.securityfocus.com/bid/9882
(VENDOR_ADVISORY)  BID  9882
http://xforce.iss.net/xforce/xfdb/15494
(VENDOR_ADVISORY)  XF  phorum-register-xss(15494)

- 漏洞信息

Phorum Multiple Module跨站脚本漏洞
中危 跨站脚本
2004-03-15 00:00:00 2005-10-20 00:00:00
远程  
        Phorum 3.1到5.0.3测试版存在多个跨站脚本漏洞。远程攻击者借助(1)login.php的HTTP_REFERER参数,(2)register.php的HTTP_REFERER参数,或(3)profile.php的target参数注入任意web脚本或HTML。

- 公告与补丁

        Fixes are available.
        Phorum Phorum 3.1
        
        Phorum Phorum 3.1.1 rc2
        
        Phorum Phorum 3.1.1 a
        
        Phorum Phorum 3.1.1 pre
        
        Phorum Phorum 3.1.1
        
        Phorum Phorum 3.1.2
        
        Phorum Phorum 3.2
        
        Phorum Phorum 3.2.2
        
        Phorum Phorum 3.2.3
        
        Phorum Phorum 3.2.3 b
        
        Phorum Phorum 3.2.3 a
        
        Phorum Phorum 3.2.4
        
        Phorum Phorum 3.2.5
        
        Phorum Phorum 3.2.6
        
        Phorum Phorum 3.2.7
        
        Phorum Phorum 3.2.8
        
        Phorum Phorum 3.3.1
        
        Phorum Phorum 3.3.1 a
        
        Phorum Phorum 3.3.2 a
        
        Phorum Phorum 3.3.2 b3
        
        Phorum Phorum 3.3.2
        
        Phorum Phorum 3.4
        
        Phorum Phorum 3.4.1
        
        Phorum Phorum 3.4.2
        
        Phorum Phorum 3.4.3
        
        Phorum Phorum 3.4.4
        
        Phorum Phorum 3.4.5
        
        Phorum Phorum 3.4.6
        

- 漏洞信息 (23818)

Phorum 3.x register.php HTTP_REFERER XSS (EDBID:23818)
php webapps
2004-03-15 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/9882/info

It has been reported that Phorum is prone to a cross-site scripting vulnerability across multiple modules. The issue presents itself across multiple modules including 'login.php', 'register.php', and 'profile.php'. These modules employ two hidden variables named 'f' and 'target', which are passed user-supplied input values from HTTP_REFERER without proper sanitization.

Phorum versions 5.0.3 Beta and prior are reported to be vulnerable to this issue.

register.php?&HTTP_REFERER=[XSS]		

- 漏洞信息 (23819)

Phorum 3.x login.php HTTP_REFERER XSS (EDBID:23819)
php webapps
2004-03-15 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/9882/info
 
It has been reported that Phorum is prone to a cross-site scripting vulnerability across multiple modules. The issue presents itself across multiple modules including 'login.php', 'register.php', and 'profile.php'. These modules employ two hidden variables named 'f' and 'target', which are passed user-supplied input values from HTTP_REFERER without proper sanitization.
 
Phorum versions 5.0.3 Beta and prior are reported to be vulnerable to this issue.

login.php?HTTP_REFERER=[XSS]		

- 漏洞信息 (23820)

Phorum 3.x profile.php target Parameter XSS (EDBID:23820)
php webapps
2004-03-15 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/9882/info
  
It has been reported that Phorum is prone to a cross-site scripting vulnerability across multiple modules. The issue presents itself across multiple modules including 'login.php', 'register.php', and 'profile.php'. These modules employ two hidden variables named 'f' and 'target', which are passed user-supplied input values from HTTP_REFERER without proper sanitization.
  
Phorum versions 5.0.3 Beta and prior are reported to be vulnerable to this issue.

profile.php?id=2&action=edit&target=[XSS]		

- 漏洞信息

4333
Phorum register.php HTTP_REFERER XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Phorum contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'HTTP_REFERER' parameter upon submission to the 'register.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-03-15 Unknow
2004-03-15 Unknow

- 解决方案

Upgrade to version 3.4.8a or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站