CVE-2004-1809
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:00:47
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in phpBB 2.0.6d and earlier allows remote attackers to inject arbitrary web script or HTML via the (1) postdays parameter to viewtopic.php or (2) topicdays parameter to viewforum.php.


[CNNVD]phpBB viewtopic.php postdays参数跨站脚本漏洞(CNNVD-200412-502)

        
        phpBB2是一款由PHP编写的WEB论坛应用程序,支持多种数据库系统,可使用在多种Unix和Linux操作系统下。
        phpBB2包含的"viewtopic.php"脚本在处理"postdays"变量时缺少充分过滤,远程攻击者可以利用这个漏洞进行跨站脚本执行攻击,可能获得用户敏感数据信息。
        脚本"viewtopic.php"在返回"postdays" HTML变量值给客户端时没有进行任何编码或删除过滤恶意代码,当目标用户连接嵌入恶意"postdays"变量数据链接时,可导致脚本代码在用户浏览器上执行,可能获得用户的敏感信息。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpbb_group:phpbb:2.0.4
cpe:/a:phpbb_group:phpbb:2.0.5
cpe:/a:phpbb_group:phpbb:2.0.2
cpe:/a:phpbb_group:phpbb:2.0.3
cpe:/a:phpbb_group:phpbb:2.0.0
cpe:/a:phpbb_group:phpbb:2.0.1
cpe:/a:phpbb_group:phpbb:2.0_rc1
cpe:/a:phpbb_group:phpbb:2.0_rc2
cpe:/a:phpbb_group:phpbb:2.0.6d
cpe:/a:phpbb_group:phpbb:2.0_rc3
cpe:/a:phpbb_group:phpbb:2.0.6c
cpe:/a:phpbb_group:phpbb:2.0_rc4
cpe:/a:phpbb_group:phpbb:2.0.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1809
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1809
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-502
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107920498205324&w=2
(UNKNOWN)  BUGTRAQ  20040313 phpBB 2.0.6d && Earlier Security Issues
http://www.phpbb.com/support/documents.php?mode=changelog#206
(UNKNOWN)  CONFIRM  http://www.phpbb.com/support/documents.php?mode=changelog#206
http://www.securityfocus.com/bid/9865
(PATCH)  BID  9865
http://www.securityfocus.com/bid/9866
(PATCH)  BID  9866
http://xforce.iss.net/xforce/xfdb/15464
(UNKNOWN)  XF  phpbb-viewforum-viewtopic-xss(15464)

- 漏洞信息

phpBB viewtopic.php postdays参数跨站脚本漏洞
中危 输入验证
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        phpBB2是一款由PHP编写的WEB论坛应用程序,支持多种数据库系统,可使用在多种Unix和Linux操作系统下。
        phpBB2包含的"viewtopic.php"脚本在处理"postdays"变量时缺少充分过滤,远程攻击者可以利用这个漏洞进行跨站脚本执行攻击,可能获得用户敏感数据信息。
        脚本"viewtopic.php"在返回"postdays" HTML变量值给客户端时没有进行任何编码或删除过滤恶意代码,当目标用户连接嵌入恶意"postdays"变量数据链接时,可导致脚本代码在用户浏览器上执行,可能获得用户的敏感信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        if( !empty($HTTP_POST_VARS['postdays']) || !empty($HTTP_GET_VARS['postdays']) )
        {
         $post_days = ( !empty($HTTP_POST_VARS['postdays']) ) ? $HTTP_POST_VARS['postdays']
        : $HTTP_GET_VARS['postdays'];
         $min_post_time = time() - (intval($post_days) * 86400);
        -----[ REPLACE WITH ]---------------------------
        if( !empty($HTTP_POST_VARS['postdays']) || !empty($HTTP_GET_VARS['postdays']) )
        {
        ///////////////////////////////////////////////////////////////////
        // Lets Do Away With These Problems By Requiring A Valid Integer //
        // Fix By JeiAr //
        http://www.gulftech.org
// Friday 03 12, 2004 //
        ///////////////////////////////////////////////////////////////////
        
         $post_days = ( !empty($HTTP_POST_VARS['postdays']) ) ? intval($HTTP_POST_VARS['postdays'])
        : intval($HTTP_GET_VARS['postdays']);
         $min_post_time = time() - (intval($post_days) * 86400);
        厂商补丁:
        phpBB Group
        -----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        phpBB Group Upgrade phpBB 2.0.7
        
        http://www.phpbb.com/downloads.php

- 漏洞信息

4257
phpBB viewforum.php topicdays Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

phpBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'topicdays' variable upon submission to the "viewforum.php" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-03-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站