发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:00:45

[原文]Cross-site scripting (XSS) vulnerability in index.cfm in CFWebstore 5.0 allows remote attackers to inject arbitrary web script or HTML via the URL.

[CNNVD]Dogpatch Software CFWebstore跨扎脚本漏洞(CNNVD-200412-747)

        index.cfm in CFWebstore 5.0版本存在跨站脚本(XSS)漏洞。远程攻击者借助URL注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040312 Dogpatch Software CFWebstore 5.0 shopping cart software multiple security vulnerabilities
(UNKNOWN)  BID  9856
(UNKNOWN)  XF  cfwebstore-url-xss(15454)

- 漏洞信息

Dogpatch Software CFWebstore跨扎脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
        index.cfm in CFWebstore 5.0版本存在跨站脚本(XSS)漏洞。远程攻击者借助URL注入任意web脚本或者HTML。

- 公告与补丁

        The vendor has supplied an upgrade dealing with this issue. Please see the reference section to contact the vendor for details on obtaining the upgrade.

- 漏洞信息

CFWebstore index.cfm URL XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

CFWebstore contains a flaw that allows a remote cross site scripting attack. This flaw exists because user input supplied in an URL is not sanitised properly before being returned to a user. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-03-12 2004-03-04
Unknow Unknow

- 解决方案

Upgrade to version 5.0.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者