CVE-2004-1806
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:00:43
NMCO    

[原文]SQL injection vulnerability in index.cfm in CFWebstore 5.0 allows remote attackers to execute SQL commands via the (1) category_id, (2) product_id, or (3) feature_id parameters.


[CNNVD]Dogpatch Software CFWebstore注入漏洞(CNNVD-200412-354)

        CFWebstore 5.0版本的index.cfm存在SQL注入漏洞。远程攻击者可以借助(1)category_id,(2)product_id, 或(3)feature_id参数执行SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1806
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1806
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-354
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107911090901744&w=2
(UNKNOWN)  BUGTRAQ  20040312 Dogpatch Software CFWebstore 5.0 shopping cart software multiple security vulnerabilities
http://securitytracker.com/id?1009403
(UNKNOWN)  SECTRACK  1009403
http://www.s-quadra.com/advisories/Adv-20040312.txt
(VENDOR_ADVISORY)  MISC  http://www.s-quadra.com/advisories/Adv-20040312.txt
http://www.securityfocus.com/bid/9854
(UNKNOWN)  BID  9854
http://xforce.iss.net/xforce/xfdb/15447
(UNKNOWN)  XF  cfwebstore-index-sql-injection(15447)

- 漏洞信息

Dogpatch Software CFWebstore注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        CFWebstore 5.0版本的index.cfm存在SQL注入漏洞。远程攻击者可以借助(1)category_id,(2)product_id, 或(3)feature_id参数执行SQL命令。

- 公告与补丁

        The vendor has supplied an upgrade dealing with this issue. Please see the reference section to contact the vendor for details on obtaining the upgrade.

- 漏洞信息

4229
CFWebstore index.cfm Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Vendor Verified

- 漏洞描述

Dogpatch CF Webstore contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the "category_id", "product_id", and "feature_id" variables in the index.cfm module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-03-12 2004-03-04
Unknow Unknow

- 解决方案

Upgrade to version 5.0.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站