CVE-2004-1779
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:42:20
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in board.php for ThWboard before beta 2.84 allows remote attackers to inject arbitrary web script or HTML via the lastvisited parameter.


[CNNVD]ThWboard board.php跨站脚本漏洞(CNNVD-200412-862)

        ThWboard 2.84测试版之前版本的board.php存在跨站脚本(XSS)漏洞。远程攻击者可以借助lastvisited参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:thwboard:thwboard_beta:2.83
cpe:/a:thwboard:thwboard_beta:2.82
cpe:/a:thwboard:thwboard_beta:2.81
cpe:/a:thwboard:thwboard_beta:2.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1779
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1779
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-862
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/9367
(PATCH)  BID  9367
http://securitytracker.com/id?1008617
(PATCH)  SECTRACK  1008617
http://secunia.com/advisories/10546
(PATCH)  SECUNIA  10546
http://cvs.sourceforge.net/viewcvs.py/thwb/thwb/board.php?r1=1.11&r2=1.12
(PATCH)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/thwb/thwb/board.php?r1=1.11&r2=1.12
http://xforce.iss.net/xforce/xfdb/14143
(UNKNOWN)  XF  thwboard-board-xss(14143)
http://www.osvdb.org/3330
(UNKNOWN)  OSVDB  3330
http://sourceforge.net/project/shownotes.php?release_id=207893
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=207893

- 漏洞信息

ThWboard board.php跨站脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        ThWboard 2.84测试版之前版本的board.php存在跨站脚本(XSS)漏洞。远程攻击者可以借助lastvisited参数注入任意web脚本或HTML。

- 公告与补丁

        This issue has been addressed in Beta 2.84.
        Thwboard Thwboard Beta 2.8
        
        Thwboard Thwboard Beta 2.81
        
        Thwboard Thwboard Beta 2.82
        
        Thwboard Thwboard Beta 2.83
        

- 漏洞信息

3330
ThWboard board.php lastvisited Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

ThWboard contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "lastvisited" variable upon submission to the board.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-01-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version Beta 2.84 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站