CVE-2004-1765
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:00:31
NMCOS    

[原文]Off-by-one buffer overflow in ModSecurity (mod_security) 1.7.4 for Apache 2.x, when SecFilterScanPost is enabled, allows remote attackers to execute arbitrary code via crafted POST requests.


[CNNVD]Apache Mod_Security模块SecFilterScanPost Off-By-One缓冲溢出漏洞(CNNVD-200412-126)

        用于Apache 2.x的ModSecurity (mod_security)1.7.4版本存在 Off-By-One缓冲溢出漏洞。远程攻击者在SecFilterScanPost有效时可以借助畸形POST请求执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1765
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1765
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-126
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107945597331370&w=2
(UNKNOWN)  BUGTRAQ  20040316 ModSecurity 1.7.4 for Apache 2.x remote off-by-one overflow
http://www.kb.cert.org/vuls/id/779438
(VENDOR_ADVISORY)  CERT-VN  VU#779438
http://www.modsecurity.org/
(UNKNOWN)  CONFIRM  http://www.modsecurity.org/
http://www.s-quadra.com/advisories/Adv-20040315.txt
(UNKNOWN)  MISC  http://www.s-quadra.com/advisories/Adv-20040315.txt
http://www.securityfocus.com/bid/9885
(PATCH)  BID  9885
http://xforce.iss.net/xforce/xfdb/15489
(UNKNOWN)  XF  mod-security-offbyone-bo(15489)

- 漏洞信息

Apache Mod_Security模块SecFilterScanPost Off-By-One缓冲溢出漏洞
高危 缓冲区溢出
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        用于Apache 2.x的ModSecurity (mod_security)1.7.4版本存在 Off-By-One缓冲溢出漏洞。远程攻击者在SecFilterScanPost有效时可以借助畸形POST请求执行任意代码。

- 公告与补丁

        The vendor has released mod_security 1.7.5 to address this issue:
        mod_security mod_security 1.7.4
        

- 漏洞信息

4304
ModSecurity (mod_security) POST Request Processing Off-By-One
Input Manipulation
Loss of Integrity

- 漏洞描述

- 时间线

2004-03-17 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Apache Mod_Security Module SecFilterScanPost Off-By-One Buffer Overflow Vulnerability
Boundary Condition Error 9885
Yes No
2004-03-16 12:00:00 2009-07-12 03:06:00
Discovery is credited to Evgeny Legerov <e.legerov@s-quadra.com>.

- 受影响的程序版本

mod_security mod_security 1.7.4
mod_security mod_security 1.7.5

- 不受影响的程序版本

mod_security mod_security 1.7.5

- 漏洞讨论

It has been reported that the Apache 2 mod_security module is affected by an off-by-one buffer overflow condition that could potentially allow a remote attacker to execute arbitrary code on a vulnerable system under some circumstances. The issue presents itself when the 'SecFilterScanPost' directive is enabled. Specifically, malformed POST data sent by a remote attacker may trigger an off-by-one buffer overflow condition.

Due to a lack of details further information cannot be provided at the moment. This BID will be updated as more information becomes available.

mod_security 1.7.4 has been reported to be prone to this issue, however, it is possible that other versions are affected as well.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

The vendor has released mod_security 1.7.5 to address this issue:


mod_security mod_security 1.7.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站