发布时间 :2004-08-21 00:00:00
修订时间 :2016-10-17 23:00:09

[原文]Cross-site scripting (XSS) vulnerability in the create list option in Sympa 4.1.x and earlier allows remote authenticated users to inject arbitrary web script or HTML via the description field.


        Sympa 4.1.x及其早期版本的创建列表选项存在跨站脚本漏洞。远程认证用户借助描述字段注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:sympa:sympa:4.1Sympa 4.1

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040820 Cross Site Scripting Vulnerability in Sympa
(VENDOR_ADVISORY)  XF  sympa-description-xss(17057)

- 漏洞信息

中危 跨站脚本
2004-08-21 00:00:00 2005-10-20 00:00:00
        Sympa 4.1.x及其早期版本的创建列表选项存在跨站脚本漏洞。远程认证用户借助描述字段注入任意web脚本或者HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (24389)

Sympa 4.x New List HTML Injection Vulnerability (EDBID:24389)
php webapps
2004-08-21 Verified
0 Jose Antonio
N/A [点击下载]

An HTML injection vulnerability is reported in Sympa. The problem occurs due to a failure of the application to properly sanitize user-supplied input data.

Unsuspecting users viewing the affected page will have attacker-supplied malicious code interpreted by their browser in the security context of the website hosting Sympa.

Attackers may potentially exploit this issue to manipulate web content or to steal cookie-based authentication credentials. It may be possible to take arbitrary actions as the victim user.

Versions 4.1, and all 4.1.x releases are reported vulnerable to this issue. 

Whatever_you_want<script>alert("Your cookie is " + document.cookie)</script> 		

- 漏洞信息

Sympa List Creation Description Field XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Sympa contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate description fields input upon submission to the admin script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-08-22 Unknow
2004-08-22 Unknow

- 解决方案

Upgrade to version 4.2b.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者