CVE-2004-1725
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:59:55
NMCOS    

[原文]Stack-based buffer overflow in xvbmp.c in XV allows remote attackers to execute arbitrary code via a crafted image file.


[CNNVD]XV多个缓冲区溢出和整数溢出漏洞(CNNVD-200412-177)

        
        xv是X Windows系统下的图象处理工具。
        xv存在多个缓冲区溢出和整数溢出,本地攻击者可以利用这个漏洞以用户进程权限在系统上执行任意指令。
        基于堆栈的缓冲区溢出存在于'xvbmp.c'源文件中,根据报告用户提供的值在拷贝到堆栈的缓冲区中没有任何边界检查,可触发溢出。
        'xviris.c'源文件存在多个基于堆的溢出,根据报告问题是由于整数处理问题。攻击者提供特殊整数值可导致内存分配问题,触发溢出。
        'xvpcx.c'源文件也存在堆的溢出,问题是整数处理问题。攻击者提供特殊整数值可导致内存分配问题,触发溢出。
        'xvpm.c'源文件也存在堆溢出问题,问题也是整数溢出问题,攻击者提供特殊整数值可导致内存分配问题,触发溢出。
        精心构建恶意图象文件,诱使用户使用xv查看恶意文件时,可能以用户进程权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1725
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1725
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-177
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109302498125092&w=2
(UNKNOWN)  BUGTRAQ  20040820 XV multiple buffer overflows, exploit included
http://www.securityfocus.com/bid/10985
(PATCH)  BID  10985
http://xforce.iss.net/xforce/xfdb/17053
(UNKNOWN)  XF  xv-image-bo(17053)

- 漏洞信息

XV多个缓冲区溢出和整数溢出漏洞
高危 边界条件错误
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        xv是X Windows系统下的图象处理工具。
        xv存在多个缓冲区溢出和整数溢出,本地攻击者可以利用这个漏洞以用户进程权限在系统上执行任意指令。
        基于堆栈的缓冲区溢出存在于'xvbmp.c'源文件中,根据报告用户提供的值在拷贝到堆栈的缓冲区中没有任何边界检查,可触发溢出。
        'xviris.c'源文件存在多个基于堆的溢出,根据报告问题是由于整数处理问题。攻击者提供特殊整数值可导致内存分配问题,触发溢出。
        'xvpcx.c'源文件也存在堆的溢出,问题是整数处理问题。攻击者提供特殊整数值可导致内存分配问题,触发溢出。
        'xvpm.c'源文件也存在堆溢出问题,问题也是整数溢出问题,攻击者提供特殊整数值可导致内存分配问题,触发溢出。
        精心构建恶意图象文件,诱使用户使用xv查看恶意文件时,可能以用户进程权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        John Bradley
        ------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.trilon.com/xv/

- 漏洞信息

9115
xv xvbmp.c Local Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A local overflow exists in xv. xv fails to properly sanitize user input in the xvbmp.c routines resulting in a stack overflow. With a specially crafted image file, an attacker can cause arbitrary code to be execute on victims system resulting in a loss of integrity.

- 时间线

2004-08-20 Unknow
2004-08-20 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Greg Roelofs has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

XV Multiple Buffer Overflow and Integer Handling Vulnerabilities
Boundary Condition Error 10985
Yes No
2004-08-20 12:00:00 2009-07-12 06:17:00
Discovery of these vulnerabilities is credited to Sean <infamous41md@hotpop.com>

- 受影响的程序版本

John Bradley XV 3.10 a
+ Gentoo Linux
+ Slackware Linux 10.1
+ Slackware Linux 10.0
+ Slackware Linux 9.1
+ Slackware Linux 9.0
+ Slackware Linux 8.1
+ Slackware Linux -current

- 漏洞讨论

xv is an image manipulation utility for the X Window System.

xv is reported prone to multiple buffer overflow and integer overflow vulnerabilities. The following issues are reported:

A stack based buffer overflow exists in the 'xvbmp.c' source file. It is reported that a user-supplied value is employed to iterate a loop that copies data into a finite stack based buffer.

Multiple heap overflow vulnerabilities are reported to exist in the 'xviris.c' source file. The vulnerabilities are reported to exist due to integer handling problems. It is reported that an attacker may supply an integer value that is employed as a value during heap based memory allocation; this value may cause the allocation of an insufficient chunk of memory.

A heap overflow vulnerability is reported to exist in the 'xvpcx.c' source file. The vulnerability is reported to exist due to integer handling problems. It is reported that an attacker may supply an integer value that is employed as a value during heap based memory allocation; this value may cause the allocation of an insufficient chunk of memory.

An additional heap overflow vulnerability is reported to exist in the 'xvpm.c' source file. The vulnerability is again reported to exist due to integer handling problems. It is reported that an attacker may supply an integer value that is employed as a value during heap based memory allocation; this value may cause the allocation of an insufficient chunk of memory.

- 漏洞利用

The following exploit is available:

- 解决方案

Gentoo has released an advisory and fixes to address this issue. Fixes may be applied by the superuser with the following commands:
emerge sync
emerge -pv ">=media-gfx/xv-3.10a-r7"
emerge ">=media-gfx/xv-3.10a-r7"

Slackware Linux has released advisory SSA:2005-195-02, along with fixes to address various issues. Please see the referenced advisory for further information.


John Bradley XV 3.10 a

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站