CVE-2004-1711
CVSS4.3
发布时间 :2004-08-06 00:00:00
修订时间 :2016-10-17 22:59:37
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in post.php in Moodle before 1.3 allows remote attackers to inject arbitrary web script or HTML via the reply parameter.


[CNNVD]Moodle 'post.php'跨站脚本漏洞(CNNVD-200408-096)

        Moodle before 1.3版本中的post.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过reply参数住入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:moodle:moodle:1.3Moodle 1.3
cpe:/a:moodle:moodle:1.2Moodle 1.2
cpe:/a:moodle:moodle:1.2.1Moodle 1.2.1
cpe:/a:moodle:moodle:1.3.1Moodle 1.3.1
cpe:/a:moodle:moodle:1.3.2Moodle 1.3.2
cpe:/a:moodle:moodle:1.3.3Moodle 1.3.3
cpe:/a:moodle:moodle:1.1.1Moodle 1.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1711
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1711
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-096
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109182851216921&w=2
(UNKNOWN)  BUGTRAQ  20040806 xss in moodle (post.php)
http://www.securityfocus.com/bid/10884
(VENDOR_ADVISORY)  BID  10884
http://xforce.iss.net/xforce/xfdb/16924
(VENDOR_ADVISORY)  XF  moodle-post-xss(16924)

- 漏洞信息

Moodle 'post.php'跨站脚本漏洞
中危 跨站脚本
2004-08-06 00:00:00 2005-10-20 00:00:00
远程  
        Moodle before 1.3版本中的post.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过reply参数住入任意web脚本或者HTML。

- 公告与补丁

        Versions 1.3.4 and newer are reported to be fixed.
        Moodle moodle 1.1.1
        
        Moodle moodle 1.2
        
        Moodle moodle 1.2.1
        
        Moodle moodle 1.3
        
        Moodle moodle 1.3.1
        
        Moodle moodle 1.3.2
        
        Moodle moodle 1.3.3
        

- 漏洞信息

8383
Moodle post.php reply Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Moodle contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "reply" variable upon submission to the "post.php" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-08-06 Unknow
2004-08-06 Unknow

- 解决方案

Upgrade to version 1.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站