发布时间 :2004-10-14 00:00:00
修订时间 :2008-09-05 16:42:06

[原文]Cross-site scripting (XSS) vulnerability in SettingsBase.php in Pinnacle ShowCenter 1.51 build 121 allows remote attackers to inject arbitrary HTML or web script via the Skin parameter, which is echoed in an error message.

[CNNVD]Pinnacle系统ShowCenter SettingsBase.PHP跨站脚本漏洞(CNNVD-200410-016)

        Pinnacle ShowCenter 1.51版本121的SettingsBase.php中存在跨站脚本(XSS)漏洞。远程攻击者可以借助错误信息的Skin参数注入任意HTML或web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  pinnacle-showcenter-xss(17708)
(UNKNOWN)  BID  11415

- 漏洞信息

Pinnacle系统ShowCenter SettingsBase.PHP跨站脚本漏洞
中危 跨站脚本
2004-10-14 00:00:00 2006-08-24 00:00:00
        Pinnacle ShowCenter 1.51版本121的SettingsBase.php中存在跨站脚本(XSS)漏洞。远程攻击者可以借助错误信息的Skin参数注入任意HTML或web脚本。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息

Pinnacle ShowCenter SettingsBase.php Skin Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity Solution Unknown
Exploit Public

- 漏洞描述

Pinnacle ShowCenter contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the Skin variable upon submission to the SettingsBase.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-10-14 2004-09-22
2004-10-14 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

Unknown or Incomplete