CVE-2004-1691
CVSS5.0
发布时间 :2004-09-18 00:00:00
修订时间 :2016-10-17 22:59:14
NMCOES    

[原文]The Web Server in DNS4Me 3.0.0.4 allows remote attackers to cause a denial of service (CPU consumption and crash) via a large amount of data.


[CNNVD]DNS4Me远程拒绝服务及跨站脚本攻击漏洞(CNNVD-200409-048)

        
        DNS4Me是一款动态DNS服务系统,可使用域名关联动态IP。
        DNS4Me存在多个安全问题,远程攻击者可以利用这些漏洞对系统进行拒绝服务及跨站脚本攻击。
        跨站脚本攻击漏洞:
        攻击者可以构建恶意URL连接,诱使用户访问, 可导致恶意代码在用户浏览器上执行,导致敏感信息泄露:
        http://127.0.0.1/?%3E%3Cscript%3Ealert('XSS')%3C/script%3E
        拒绝服务攻击:
        恶意用户可以发送超大数据到80端口,或DNS4Me Web服务程序运行的端口,可导致CPU使用率达到99%而造成拒绝服务。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1691
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1691
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200409-048
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109552436811493&w=2
(UNKNOWN)  BUGTRAQ  20040918 RhinoSoft DNS4ME HTTP Server Vulnerabilities
http://securitytracker.com/id?1011334
(VENDOR_ADVISORY)  SECTRACK  1011334
http://www.gulftech.org/?node=research&article_id=00049-09162004
(VENDOR_ADVISORY)  MISC  http://www.gulftech.org/?node=research&article_id=00049-09162004
http://www.securityfocus.com/bid/11213
(VENDOR_ADVISORY)  BID  11213
http://xforce.iss.net/xforce/xfdb/17426
(VENDOR_ADVISORY)  XF  dns4me-dos(17426)

- 漏洞信息

DNS4Me远程拒绝服务及跨站脚本攻击漏洞
中危 输入验证
2004-09-18 00:00:00 2005-10-20 00:00:00
远程  
        
        DNS4Me是一款动态DNS服务系统,可使用域名关联动态IP。
        DNS4Me存在多个安全问题,远程攻击者可以利用这些漏洞对系统进行拒绝服务及跨站脚本攻击。
        跨站脚本攻击漏洞:
        攻击者可以构建恶意URL连接,诱使用户访问, 可导致恶意代码在用户浏览器上执行,导致敏感信息泄露:
        http://127.0.0.1/?%3E%3Cscript%3Ealert('XSS')%3C/script%3E
        拒绝服务攻击:
        恶意用户可以发送超大数据到80端口,或DNS4Me Web服务程序运行的端口,可导致CPU使用率达到99%而造成拒绝服务。
        

- 公告与补丁

        厂商补丁:
        RhinoSoft
        ---------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.dns4me.com/

- 漏洞信息 (24610)

DNS4Me 3.0 Denial Of Service And Cross-Site Scripting Vulnerabilities (EDBID:24610)
multiple webapps
2004-09-17 Verified
0 James Bercegay
N/A [点击下载]
source: http://www.securityfocus.com/bid/11213/info

DNS4Me is reported to be susceptible to a denial of service vulnerability, and a cross-site scripting vulnerability. These vulnerabilities affect the built-in web server contained in the package.

The first vulnerability reportedly allows attackers to cause the web server to consume all available CPU resources, and eventually crash the application.

The second vulnerability is due to a failure of the application to properly sanitize user-supplied URI input. This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

Although these vulnerabilities are reported to exist in version 3.0.0.4 of DNS4Me, other versions may also be affected.

http://www.example.com/?%3E%3Cscript%3Ealert('XSS')%3C/script%3E		

- 漏洞信息

10039
DNS4Me Web Server GET Request Overflow DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability Upgrade
Exploit Public Vendor Verified

- 漏洞描述

DNS4Me contains a flaw that may allow a remote denial of service. The issue is triggered when sending a large amount of data to port 80, which causes the service to consume all available CPU resources and eventually crash resulting in a loss of availability.

- 时间线

2004-09-16 Unknow
2004-09-16 2004-11-16

- 解决方案

Upgrade to version 4.0.0.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

DNS4Me Denial Of Service And Cross-Site Scripting Vulnerabilities
Input Validation Error 11213
Yes No
2004-09-17 12:00:00 2009-07-12 07:06:00
James Bercegay of the GulfTech Security Research Team is credited for the discovery of these vulnerabilities.

- 受影响的程序版本

RhinoSoft DNS4Me 3.0 .0.4

- 漏洞讨论

DNS4Me is reported to be susceptible to a denial of service vulnerability, and a cross-site scripting vulnerability. These vulnerabilities affect the built-in web server contained in the package.

The first vulnerability reportedly allows attackers to cause the web server to consume all available CPU resources, and eventually crash the application.

The second vulnerability is due to a failure of the application to properly sanitize user-supplied URI input. This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

Although these vulnerabilities are reported to exist in version 3.0.0.4 of DNS4Me, other versions may also be affected.

- 漏洞利用

An exploit is not required. An example URI sufficient to exploit the cross-site scripting vulnerability was provided:

http://www.example.com/?%3E%3Cscript%3Ealert('XSS')%3C/script%3E

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站