CVE-2004-1690
CVSS4.3
发布时间 :2004-09-18 00:00:00
修订时间 :2016-10-17 22:59:12
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in the Web Server in DNS4Me 3.0.0.4 allows remote attackers to execute arbitrary web script or HTML via the URL.


[CNNVD]DNS4Me远程拒绝服务及跨站脚本攻击漏洞(CNNVD-200409-051)

        
        DNS4Me是一款动态DNS服务系统,可使用域名关联动态IP。
        DNS4Me存在多个安全问题,远程攻击者可以利用这些漏洞对系统进行拒绝服务及跨站脚本攻击。
        跨站脚本攻击漏洞:
        攻击者可以构建恶意URL连接,诱使用户访问, 可导致恶意代码在用户浏览器上执行,导致敏感信息泄露:
        http://127.0.0.1/?%3E%3Cscript%3Ealert('XSS')%3C/script%3E
        拒绝服务攻击:
        恶意用户可以发送超大数据到80端口,或DNS4Me Web服务程序运行的端口,可导致CPU使用率达到99%而造成拒绝服务。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1690
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1690
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200409-051
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109552436811493&w=2
(UNKNOWN)  BUGTRAQ  20040918 RhinoSoft DNS4ME HTTP Server Vulnerabilities
http://securitytracker.com/id?1011334
(VENDOR_ADVISORY)  SECTRACK  1011334
http://www.gulftech.org/?node=research&article_id=00049-09162004
(VENDOR_ADVISORY)  MISC  http://www.gulftech.org/?node=research&article_id=00049-09162004
http://www.securityfocus.com/bid/11213
(VENDOR_ADVISORY)  BID  11213
http://xforce.iss.net/xforce/xfdb/17425
(VENDOR_ADVISORY)  XF  dns4me-xss(17425)

- 漏洞信息

DNS4Me远程拒绝服务及跨站脚本攻击漏洞
中危 输入验证
2004-09-18 00:00:00 2005-10-20 00:00:00
远程  
        
        DNS4Me是一款动态DNS服务系统,可使用域名关联动态IP。
        DNS4Me存在多个安全问题,远程攻击者可以利用这些漏洞对系统进行拒绝服务及跨站脚本攻击。
        跨站脚本攻击漏洞:
        攻击者可以构建恶意URL连接,诱使用户访问, 可导致恶意代码在用户浏览器上执行,导致敏感信息泄露:
        http://127.0.0.1/?%3E%3Cscript%3Ealert('XSS')%3C/script%3E
        拒绝服务攻击:
        恶意用户可以发送超大数据到80端口,或DNS4Me Web服务程序运行的端口,可导致CPU使用率达到99%而造成拒绝服务。
        

- 公告与补丁

        厂商补丁:
        RhinoSoft
        ---------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.dns4me.com/

- 漏洞信息

10038
DNS4Me GET Request XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

DNS4Me contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate HTTP GET requests. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-09-16 Unknow
2004-09-16 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站