CVE-2004-1659
CVSS4.3
发布时间 :2004-09-02 00:00:00
修订时间 :2016-10-17 22:58:36
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in index.php in CuteNews 1.3.6 and earlier allows remote attackers with Administrator, Editor, Journalist or Commenter privileges to inject arbitrary web script or HTML via the mod parameter.


[CNNVD]CuteNews 'index.php'跨站脚本漏洞(CNNVD-200409-008)

        CuteNews 1.3.6及其早期版本的index.php存在跨站脚本漏洞。有管理员,编辑,记者或者评论家特权的远程攻击者借助mod参数注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:cutephp:cutenews:0.88
cpe:/a:cutephp:cutenews:1.3.2
cpe:/a:cutephp:cutenews:1.3
cpe:/a:cutephp:cutenews:1.3.1
cpe:/a:cutephp:cutenews:1.3.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1659
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1659
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200409-008
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109415338521881&w=2
(UNKNOWN)  BUGTRAQ  20040902 [hackgen-2004-#001] - Non-critacal Cross-Site Scripting bug in CuteNews
http://www.securityfocus.com/bid/11097
(VENDOR_ADVISORY)  BID  11097
http://xforce.iss.net/xforce/xfdb/17214
(VENDOR_ADVISORY)  XF  cutenews-mod-xss(17214)

- 漏洞信息

CuteNews 'index.php'跨站脚本漏洞
中危 跨站脚本
2004-09-02 00:00:00 2005-10-20 00:00:00
远程  
        CuteNews 1.3.6及其早期版本的index.php存在跨站脚本漏洞。有管理员,编辑,记者或者评论家特权的远程攻击者借助mod参数注入任意web脚本或者HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (24566)

CuteNews 0.88/1.3.x 'index.php' Cross-Site Scripting Vulnerability (EDBID:24566)
php webapps
2004-09-02 Verified
0 Exoduks
N/A [点击下载]
source: http://www.securityfocus.com/bid/11097/info

It is reported that CuteNews is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

This vulnerability is reported to exist in versions 1.3.6 and prior of CuteNews.

http://www.example.com/cutenews/index.php?mod=[XSS CODE]
http://www.example.com/cutenews/index.php?mod=<script>alert(document.cookie)</script>		

- 漏洞信息

9558
CuteNews index.php mod Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

CuteNews contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the mod variable upon submission to the index.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-09-02 Unknow
2004-09-02 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站