CVE-2004-1580
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:56:57
NMCOE    

[原文]SQL injection vulnerability in index.php in CubeCart 2.0.1 allows remote attackers to execute arbitrary SQL commands via the cat_id parameter.


[CNNVD]Brooky CubeCart SQL注入漏洞(CNNVD-200412-179)

        CubeCart 2.0.1版本中的index.php存在SQL注入漏洞。远程攻击者可以借助cat_id参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1580
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1580
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-179
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109713382400457&w=2
(UNKNOWN)  BUGTRAQ  20041006 Full path disclosure and sql injection on CubeCart 2.0.1
http://www.exploit-db.com/exploits/15278
(UNKNOWN)  EXPLOIT-DB  15278
http://www.securityfocus.com/bid/11337
(UNKNOWN)  BID  11337
http://xforce.iss.net/xforce/xfdb/17632
(UNKNOWN)  XF  cubecart-catid-sql-injection(17632)

- 漏洞信息

Brooky CubeCart SQL注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        CubeCart 2.0.1版本中的index.php存在SQL注入漏洞。远程攻击者可以借助cat_id参数执行任意SQL命令。

- 公告与补丁

        The vendor has recommended the following fix:
        INSERT
        if (!is_numeric($cat_id))
         unset($cat_id);
        BEFORE
        include("header.inc.php");
        IN
        index.php

- 漏洞信息 (24658)

Brooky CubeCart 2.0.1 SQL Injection Vulnerability (EDBID:24658)
php webapps
2004-10-06 Verified
0 Pedro Sanches
N/A [点击下载]
source: http://www.securityfocus.com/bid/11337/info

It is reported that CubeCart is susceptible to an SQL injection vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI data prior to including it in an SQL query.

An attacker may exploit this issue to manipulate SQL queries, potentially revealing or corrupting sensitive database data. This issue may also facilitate attacks against the underlying database software.

This vulnerability is reported to exist in version 2.0.1 of CubeCart. Other versions may also be affected.

http://www.example.com/store/index.php?cat_id=1 or 1=1		

- 漏洞信息

10584
CubeCart index.php cat_id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

CubeCart contains a flaw that will allow a remote attacker to inject arbitrary SQL code. The problem is that the 'cat_id' parameter in the 'index.php' script is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-10-06 2004-10-02
2004-10-06 Unknow

- 解决方案

Upgrade to version 2.0.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站