CVE-2004-1574
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:56:50
NMCO    

[原文]Buffer overflow in Vypress Messenger 3.5.1 and earlier allows remote attackers to execute arbitrary code via a message with a long first field.


[CNNVD]VyPRESS Messenger远程缓冲区溢出漏洞(CNNVD-200412-1028)

        Vypress Messenger 3.5.1及其以前的版本存在缓冲区溢出漏洞。远程攻击者借助具有超长首字段的消息执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1574
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1574
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1028
(官方数据源) CNNVD

- 其它链接及资源

http://aluigi.altervista.org/adv/vymesbof-adv.txt
(PATCH)  MISC  http://aluigi.altervista.org/adv/vymesbof-adv.txt
http://marc.info/?l=bugtraq&m=109665993315769&w=2
(UNKNOWN)  BUGTRAQ  20041001 Broadcast buffer-overflow in Vypress Messenger 3.5.1
http://securitytracker.com/id?1011489
(UNKNOWN)  SECTRACK  1011489
http://www.securityfocus.com/bid/11310
(PATCH)  BID  11310
http://xforce.iss.net/xforce/xfdb/17572
(UNKNOWN)  XF  vypress-visual-bo(17572)

- 漏洞信息

VyPRESS Messenger远程缓冲区溢出漏洞
高危 缓冲区溢出
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Vypress Messenger 3.5.1及其以前的版本存在缓冲区溢出漏洞。远程攻击者借助具有超长首字段的消息执行任意代码。

- 公告与补丁

        VyPRESS has released version 4.0 RC1 of the affected software dealing with this issue.
        VyPRESS Messenger 3.5
        
        VyPRESS Messenger 3.5.1
        

- 漏洞信息

10451
Vypress Messenger Message Field Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

VyPRESS contains a flaw that may allow a malicious user to create a remote buffer overflow. The issue is triggered when a message is sent containing 776 characters in field #1. It is possible that the flaw may allow execution of arbitrary code with the privileges of the user running the program resulting in a loss of integrity.

- 时间线

2004-10-01 Unknow
2004-10-01 Unknow

- 解决方案

Upgrade to version 4.0 RC1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站