CVE-2004-1559
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:56:29
NMCOE    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Wordpress 1.2 allow remote attackers to inject arbitrary web script or HTML via the (1) redirect_to, text, popupurl, or popuptitle parameters to wp-login.php, (2) redirect_url parameter to admin-header.php, (3) popuptitle, popupurl, content, or post_title parameters to bookmarklet.php, (4) cat_ID parameter to categories.php, (5) s parameter to edit.php, or (6) s or mode parameter to edit-comments.php.


[CNNVD]Wordpress多个跨站脚本漏洞(CNNVD-200412-137)

        Wordpress 1.2版本存在多个跨站脚本(XSS)漏洞。远程攻击者可以借助各种参数注入任意web脚本或HTMl,这些参数包括(1)wp-login.php的redirect_to,text,popupurl或popuptitle参数,(2)admin-header.php的redirect_url参数(3)bookmarklet.php的 popuptitle,popupurl, content或post_title参数(4)categories.php的cat_ID 参数(5)edit.php的s参数或 (6)edit-comments.php的s或mode参数。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1559
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1559
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-137
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109641484723194&w=2
(UNKNOWN)  BUGTRAQ  20040927 Multiple XSS Vulnerabilities in Wordpress 1.2
http://securitytracker.com/id?1011440
(UNKNOWN)  SECTRACK  1011440
http://www.securityfocus.com/bid/11268
(PATCH)  BID  11268
http://xforce.iss.net/xforce/xfdb/17532
(PATCH)  XF  wordpress-multiple-scripts-xss(17532)

- 漏洞信息

Wordpress多个跨站脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Wordpress 1.2版本存在多个跨站脚本(XSS)漏洞。远程攻击者可以借助各种参数注入任意web脚本或HTMl,这些参数包括(1)wp-login.php的redirect_to,text,popupurl或popuptitle参数,(2)admin-header.php的redirect_url参数(3)bookmarklet.php的 popuptitle,popupurl, content或post_title参数(4)categories.php的cat_ID 参数(5)edit.php的s参数或 (6)edit-comments.php的s或mode参数。

- 公告与补丁

        The vendor has released WordPress version 1.2.1 to address these issues.
        Update: It is reported that version 1.2.1 did not completely fix these issues. It is reported that version 1.2.2 has been released, and that it fixes all issues described in this BID.
        WordPress WordPress 1.2
        
        WordPress WordPress 1.2.1
        

- 漏洞信息 (24641)

WordPress 1.2 wp-login.php Multiple Parameter XSS (EDBID:24641)
php webapps
2004-09-28 Verified
0 Thomas Waldegger
N/A [点击下载]
source: http://www.securityfocus.com/bid/11268/info

It is reported that Wordpress is affected by various cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input. 

Wordpress 1.2 is reported vulnerable, however, other versions may be affected as well.

/wp-login.php?redirect_to=[XSS]
/wp-login.php?mode=bookmarklet&text=[XSS]
/wp-login.php?mode=bookmarklet&popupurl=[XSS]
/wp-login.php?mode=bookmarklet&popuptitle=[XSS]
		

- 漏洞信息 (24642)

WordPress 1.2 admin-header.php redirect_url Parameter XSS (EDBID:24642)
php webapps
2004-09-28 Verified
0 Thomas Waldegger
N/A [点击下载]
source: http://www.securityfocus.com/bid/11268/info
 
It is reported that Wordpress is affected by various cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.
 
Wordpress 1.2 is reported vulnerable, however, other versions may be affected as well.

/admin-header.php?redirect=1&redirect_url=%22;alert(document.cookie)//		

- 漏洞信息 (24643)

WordPress 1.2 bookmarklet.php Multiple Parameter XSS (EDBID:24643)
php webapps
2004-09-28 Verified
0 Thomas Waldegger
N/A [点击下载]
source: http://www.securityfocus.com/bid/11268/info
 
It is reported that Wordpress is affected by various cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.
 
Wordpress 1.2 is reported vulnerable, however, other versions may be affected as well.

/bookmarklet.php?popuptitle=[XSS]
/bookmarklet.php?popupurl=[XSS]
/bookmarklet.php?content=[XSS]
/bookmarklet.php?post_title=[XSS]		

- 漏洞信息 (24644)

WordPress 1.2 categories.php cat_ID Parameter XSS (EDBID:24644)
php webapps
2004-09-28 Verified
0 Thomas Waldegger
N/A [点击下载]
source: http://www.securityfocus.com/bid/11268/info
 
It is reported that Wordpress is affected by various cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.
 
Wordpress 1.2 is reported vulnerable, however, other versions may be affected as well.

/categories.php?action=edit&cat_ID=[XSS]		

- 漏洞信息 (24645)

WordPress 1.2 edit.php s Parameter XSS (EDBID:24645)
php webapps
2004-09-28 Verified
0 Thomas Waldegger
N/A [点击下载]
source: http://www.securityfocus.com/bid/11268/info
 
It is reported that Wordpress is affected by various cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.
 
Wordpress 1.2 is reported vulnerable, however, other versions may be affected as well.

/edit.php?s=[XSS]		

- 漏洞信息 (24646)

WordPress 1.2 edit-comments.php Multiple Parameter XSS (EDBID:24646)
php webapps
2004-09-28 Verified
0 Thomas Waldegger
N/A [点击下载]
source: http://www.securityfocus.com/bid/11268/info
 
It is reported that Wordpress is affected by various cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.
 
Wordpress 1.2 is reported vulnerable, however, other versions may be affected as well.

/edit-comments.php?s=[XSS]
/edit-comments.php?mode=[XSS]		

- 漏洞信息

10410
WordPress wp-login.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

WordPress contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate multiple variables upon submission to the 'wp-login.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-09-27 Unknow
2004-09-27 Unknow

- 解决方案

Upgrade to version 1.5.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站