CVE-2004-1518
CVSS4.6
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:55:37
NMCO    

[原文]SQL injection vulnerability in follow.php in Phorum 5.0.12 and earlier allows remote authenticated users to execute arbitrary SQL command via the forum_id parameter.


[CNNVD]Phorum follow.php脚本远程SQL注入漏洞(CNNVD-200412-307)

        
        Phorum是一款基于PHP的WEB论坛程序。
        Phorum包含的'follow.php'脚本不正确过滤用户提交的URL数据,远程攻击者可以利用这个漏洞进行SQL注入攻击。
        'follow.php'对"$thread" 参数缺少充分过滤,攻击者提交包含恶意SQL命令的数据作为此参数数据,可更改原来的SQL逻辑,获得敏感信息,如管理员的密码HASH数据。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1518
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1518
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-307
(官方数据源) CNNVD

- 其它链接及资源

http://lists.grok.org.uk/pipermail/full-disclosure/2004-November/028609.html
(VENDOR_ADVISORY)  FULLDISC  20041111 [waraxe-2004-SA#037 - Sql injection bug in Phorum 5.0.12 and older versions]
http://marc.info/?l=bugtraq&m=110021385926870&w=2
(UNKNOWN)  BUGTRAQ  20041111 [waraxe-2004-SA#037 - Sql injection bug in Phorum 5.0.12 and older versions]
http://www.securityfocus.com/bid/11660
(PATCH)  BID  11660
http://xforce.iss.net/xforce/xfdb/18045
(PATCH)  XF  phorum-followphp-sql-injection(18045)

- 漏洞信息

Phorum follow.php脚本远程SQL注入漏洞
中危 输入验证
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Phorum是一款基于PHP的WEB论坛程序。
        Phorum包含的'follow.php'脚本不正确过滤用户提交的URL数据,远程攻击者可以利用这个漏洞进行SQL注入攻击。
        'follow.php'对"$thread" 参数缺少充分过滤,攻击者提交包含恶意SQL命令的数据作为此参数数据,可更改原来的SQL逻辑,获得敏感信息,如管理员的密码HASH数据。
        

- 公告与补丁

        厂商补丁:
        Phorum
        ------
        Phorum version 5.0.13不存在此漏洞,建议用户下载使用:
        
        http://phorum.org/downloads.php

- 漏洞信息

11676
Phorum follow.php thread Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Phorum contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the thread variable in the follow.php module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-11-11 Unknow
2004-11-11 Unknow

- 解决方案

Upgrade to version 5.0.13 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站