CVE-2004-1505
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:55:20
NMCO    

[原文]Directory traversal vulnerability in index.php in Just Another Flat file (JAF) CMS 3.0RC allows remote attackers to read arbitrary files and possibly execute PHP code via a .. (dot dot) in the show parameter.


[CNNVD]JAF CMS目录遍历运行脚本代码执行和信息泄漏漏洞(CNNVD-200412-550)

        Just Another Flat file(JAF) CMS 3.0RC的 index.php存在目录遍历漏洞。远程攻击者可以借助show参数中的..(点 点)读取任意文件并可能执行PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1505
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1505
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-550
(官方数据源) CNNVD

- 其它链接及资源

http://echo.or.id/adv/adv08-y3dips-2004.txt
(VENDOR_ADVISORY)  MISC  http://echo.or.id/adv/adv08-y3dips-2004.txt
http://marc.info/?l=bugtraq&m=110004150430309&w=2
(UNKNOWN)  BUGTRAQ  20041109 Vulnerabilities in JAF CMS
http://www.securityfocus.com/bid/11627
(PATCH)  BID  11627
http://xforce.iss.net/xforce/xfdb/17983
(PATCH)  XF  jaf-cms-file-inlcude(17983)

- 漏洞信息

JAF CMS目录遍历运行脚本代码执行和信息泄漏漏洞
高危 路径遍历
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Just Another Flat file(JAF) CMS 3.0RC的 index.php存在目录遍历漏洞。远程攻击者可以借助show参数中的..(点 点)读取任意文件并可能执行PHP代码。

- 公告与补丁

        The vendor has released a fixed version of 3.0 RC to resolve this issue:
        Salims Softhouse JAF CMS 1.0
        
        Salims Softhouse JAF CMS 1.5
        
        Salims Softhouse JAF CMS 2.0
        
        Salims Softhouse JAF CMS 2.0.5
        
        Salims Softhouse JAF CMS 2.1 .0
        
        Salims Softhouse JAF CMS 2.5
        
        Salims Softhouse JAF CMS 3.0 RC
        

- 漏洞信息

11535
JAF CMS config.php Arbitrary Local File Inclusion
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

JAF CMS allows a remote attacker to include arbitrary local files. Input given to the "show" parameter of "config.php" is not properly sanitized before it is referenced to include a file. This vulnerability can be leveraged to include arbitrary files from the local system, resulting in information disclosure in the case of text files and script execution in the case of php scripts.

- 时间线

2004-11-08 2004-11-08
2004-11-08 Unknow

- 解决方案

Upgrade to the most recent release of version 3.0 RC or more recent. Previous release of 3.0 RC are vulnerable. If you are unsure which distribution of 3.0 RC you are using, upgrade.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站