CVE-2004-1453
CVSS2.1
发布时间 :2004-12-31 00:00:00
修订时间 :2010-08-21 00:22:32
NMCO    

[原文]GNU glibc 2.3.4 before 2.3.4.20040619, 2.3.3 before 2.3.3.20040420, and 2.3.2 before 2.3.2-r10 does not restrict the use of LD_DEBUG for a setuid program, which allows local users to gain sensitive information, such as the list of symbols used by the program.


[CNNVD]Glibc LD_DEBUG访问错误信息泄露漏洞(CNNVD-200412-194)

        
        glibc是绝大多数Linux操作系统中C库的实现。
        glibc存在访问验证错误,本地攻击者可以利用这个漏洞访问部分敏感信息。
        Brad Spengler报告glibc库中存在一个漏洞,允许在setuid属性的程序上进行LD_DEBUG。这使得本地用户可以查看setuid应用程序的符号列表及这些符号的位置,获得敏感信息。
        

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gnu:glibc:2.1.9GNU glibc 2.1.9
cpe:/a:gnu:glibc:2.1.2GNU glibc 2.1.2
cpe:/a:gnu:glibc:2.0.3GNU glibc 2.0.3
cpe:/a:gnu:glibc:2.0.4GNU glibc 2.0.4
cpe:/a:gnu:glibc:2.1.1GNU glibc 2.1.1
cpe:/a:gnu:glibc:2.2.5GNU glibc 2.2.5
cpe:/a:gnu:glibc:2.1GNU glibc 2.1
cpe:/a:gnu:glibc:2.3.3GNU glibc 2.3.3
cpe:/a:gnu:glibc:2.2.4GNU glibc 2.2.4
cpe:/a:gnu:glibc:2.0GNU glibc 2.0
cpe:/a:gnu:glibc:2.1.3.10
cpe:/a:gnu:glibc:2.2.1GNU glibc 2.2.1
cpe:/a:gnu:glibc:2.1.3GNU glibc 2.1.3
cpe:/a:gnu:glibc:2.0.5GNU glibc 2.0.5
cpe:/a:gnu:glibc:2.3.1GNU glibc 2.3.1
cpe:/a:gnu:glibc:2.0.1GNU glibc 2.0.1
cpe:/a:gnu:glibc:2.3.2GNU glibc 2.3.2
cpe:/a:gnu:glibc:2.2GNU glibc 2.2
cpe:/a:gnu:glibc:2.2.2GNU glibc 2.2.2
cpe:/a:gnu:glibc:2.3.4GNU glibc 2.3.4
cpe:/a:gnu:glibc:2.3GNU glibc 2.3
cpe:/a:gnu:glibc:2.2.3GNU glibc 2.2.3
cpe:/a:gnu:glibc:2.1.1.6GNU glibc 2.1.1.6
cpe:/a:gnu:glibc:2.0.6GNU glibc 2.0.6
cpe:/a:gnu:glibc:2.0.2GNU glibc 2.0.2

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10762GNU glibc 2.3.4 before 2.3.4.20040619, 2.3.3 before 2.3.3.20040420, and 2.3.2 before 2.3.2-r10 does not restrict the use of LD_DEBUG for a s...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1453
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1453
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-194
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/10963
(PATCH)  BID  10963
http://secunia.com/advisories/12306
(PATCH)  SECUNIA  12306
http://xforce.iss.net/xforce/xfdb/17006
(UNKNOWN)  XF  glibc-suid-info-disclosure(17006)
http://www.redhat.com/support/errata/RHSA-2005-261.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2005:261
http://www.redhat.com/support/errata/RHSA-2005-256.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2005:256
http://www.gentoo.org/security/en/glsa/glsa-200408-16.xml
(UNKNOWN)  GENTOO  GLSA-200408-16
http://bugs.gentoo.org/show_bug.cgi?id=59526
(UNKNOWN)  MISC  http://bugs.gentoo.org/show_bug.cgi?id=59526

- 漏洞信息

Glibc LD_DEBUG访问错误信息泄露漏洞
低危 设计错误
2004-12-31 00:00:00 2005-10-20 00:00:00
本地  
        
        glibc是绝大多数Linux操作系统中C库的实现。
        glibc存在访问验证错误,本地攻击者可以利用这个漏洞访问部分敏感信息。
        Brad Spengler报告glibc库中存在一个漏洞,允许在setuid属性的程序上进行LD_DEBUG。这使得本地用户可以查看setuid应用程序的符号列表及这些符号的位置,获得敏感信息。
        

- 公告与补丁

        厂商补丁:
        GNU
        ---
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.gnu.org

- 漏洞信息

9010
GNU C Library (glibc) SUID Binary Debugging Information Disclosure
Local Access Required Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

glibc contains a flaw that may lead to an unauthorized information disclosure. LD_DEBUG is allowed on setuid binaries which as a result may allow a local attacker to debug a setuid binary and gain sensitive information about the system, resulting in a loss of confidentiality.

- 时间线

2004-08-16 Unknow
2004-08-16 Unknow

- 解决方案

Upgrade to version 2.3.4.20040619-r1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站