CVE-2004-1445
CVSS3.7
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:41:23
NMCO    

[原文]A race condition in nessus-adduser in Nessus 2.0.11 and possibly earlier versions, if the TMPDIR environment variable is not set, allows local users to gain privileges.


[CNNVD]Nessus以不安全方式创建临时文件漏洞(CNNVD-200412-216)

        
        Nessus是一款流行的漏洞扫描程序。
        Nessus的'nessus-adduser'以不安全方式创建临时文件,本地攻击者可以利用这个漏洞破坏系统文件。
        'nessus-adduser'脚本用于增加Nessus用户,当建立用户时,Nessus以不安全方式创建临时文件,非特权用户可以通过符号链接,当管理员增加用户执行脚本时,导致目标文件破坏,可能存在提升权限问题。
        

- CVSS (基础分值)

CVSS分值: 3.7 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:nessus:nessus:2.0.9
cpe:/a:nessus:nessus:2.0.10
cpe:/a:nessus:nessus:2.0.6
cpe:/a:nessus:nessus:2.0.5
cpe:/a:nessus:nessus:2.0.8
cpe:/a:nessus:nessus:2.0.1
cpe:/a:nessus:nessus:2.0
cpe:/a:nessus:nessus:2.0.7
cpe:/a:nessus:nessus:2.1.0
cpe:/a:nessus:nessus:2.0.2
cpe:/a:nessus:nessus:2.0.4
cpe:/a:nessus:nessus:2.0.11
cpe:/a:nessus:nessus:2.0.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1445
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1445
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-216
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/10784
(PATCH)  BID  10784
http://www.gentoo.org/security/en/glsa/glsa-200408-11.xml
(PATCH)  GENTOO  GLSA-200408-11
http://secunia.com/advisories/12127/
(PATCH)  SECUNIA  12127
http://xforce.iss.net/xforce/xfdb/16768
(UNKNOWN)  XF  nessus-adduser-race-condition(16768)

- 漏洞信息

Nessus以不安全方式创建临时文件漏洞
低危 竞争条件
2004-12-31 00:00:00 2005-10-20 00:00:00
本地  
        
        Nessus是一款流行的漏洞扫描程序。
        Nessus的'nessus-adduser'以不安全方式创建临时文件,本地攻击者可以利用这个漏洞破坏系统文件。
        'nessus-adduser'脚本用于增加Nessus用户,当建立用户时,Nessus以不安全方式创建临时文件,非特权用户可以通过符号链接,当管理员增加用户执行脚本时,导致目标文件破坏,可能存在提升权限问题。
        

- 公告与补丁

        厂商补丁:
        Nessus
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Nessus Upgrade Nessus 2.0.12
        
        http://ftp.nessus.org/nessus/nessus-2.0.12/src/

        Nessus Upgrade Nessus 2.1.1
        
        http://ftp.nessus.org/nessus/nessus-2.1.1/src/

- 漏洞信息

8167
Nessus nessus-adduser Race Condition
Local Access Required Race Condition
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

Nessus contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered by a race condition when users do not configure their TMPDIR variable. This flaw may lead to a loss of Integrity.

- 时间线

2004-07-22 Unknow
2004-07-22 Unknow

- 解决方案

Upgrade to version 2.0.12 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站