发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:41:23

[原文]Cross-site scripting (XSS) vulnerability in the inline MIME viewer in Horde-IMP (Internet Messaging Program) 3.2.4 and earlier, when used with Internet Explorer, allows remote attackers to inject arbitrary web script or HTML via an e-mail message.

[CNNVD]Horde IMP HTML+TIME HTML注入脚本(CNNVD-200412-1200)

        Horde-IMP (互联网通讯软件) 3.2.4及其早期版本中的inline MIME viewer存在跨站脚本(XSS)漏洞。当与Internet Explorer一起使用时,远程攻击者可以通过一封邮件来注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:horde:imp:3.0Horde IMP 3.0
cpe:/a:horde:imp:3.1Horde IMP 3.1
cpe:/a:horde:imp:2.2.3Horde IMP 2.2.3
cpe:/a:horde:imp:2.2.1Horde IMP 2.2.1
cpe:/a:horde:imp:3.1.2Horde IMP 3.1.2
cpe:/a:horde:imp:2.2.6Horde IMP 2.2.6
cpe:/a:horde:imp:2.2.8Horde IMP 2.2.8
cpe:/a:horde:imp:3.2.4Horde IMP 3.2.4
cpe:/a:horde:imp:2.2.7Horde IMP 2.2.7
cpe:/a:horde:imp:2.2.4Horde IMP 2.2.4
cpe:/a:horde:imp:2.2.5Horde IMP 2.2.5
cpe:/a:horde:imp:3.2.1Horde IMP 3.2.1
cpe:/a:horde:imp:2.0Horde IMP 2.0
cpe:/a:horde:imp:3.2.3Horde IMP 3.2.3
cpe:/a:horde:imp:3.2Horde IMP 3.2
cpe:/a:horde:imp:3.2.2Horde IMP 3.2.2
cpe:/a:horde:imp:2.2.2Horde IMP 2.2.2
cpe:/a:horde:imp:2.2Horde IMP 2.2
cpe:/a:horde:imp:2.3Horde IMP 2.3

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  10845
(PATCH)  GENTOO  GLSA-200408-07
(UNKNOWN)  XF  imp-html-viewer-xss(16866)

- 漏洞信息

中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
        Horde-IMP (互联网通讯软件) 3.2.4及其早期版本中的inline MIME viewer存在跨站脚本(XSS)漏洞。当与Internet Explorer一起使用时,远程攻击者可以通过一封邮件来注入任意web脚本或HTML。

- 公告与补丁

        The vendor has released an upgrade dealing with this issue.
        Gentoo has released an advisory (GLSA 200408-07) to address this issue. Please see the referenced advisory for more information. Gentoo users may carry out the following commands to update their computers:
        emerge sync
        emerge -pv ">=horde-imp-3.2.5"
        emerge ">=horde-imp-3.2.5"
        Horde IMP 3.0
        Horde IMP 3.1
        Horde IMP 3.1.2
        Horde IMP 3.2
        Horde IMP 3.2.1
        Horde IMP 3.2.2
        Horde IMP 3.2.3
        Horde IMP 3.2.4

- 漏洞信息

Horde IMP with MSIE MIME Viewer E-mail Message XSS
Remote / Network Access Input Manipulation, Other
Loss of Integrity
Exploit Public

- 漏洞描述

Horde IMP contains a flaw that allows a remote scripting attack. This issue is due to an input validation error in the IE HTML viewer. An Internet Explorer technology called HTML+TIME (based on SMIL)could be invoked to manipulate any attribute on an element via special control elements to execute malicious scripting code. This allows a remote attacker to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-08-03 Unknow
2004-08-03 Unknow

- 解决方案

Upgrade to version 3.2.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete