CVE-2004-1440
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:54:42
NMCO    

[原文]Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.


[CNNVD]PuTTY/PSCP远程任意指令执行漏洞(CNNVD-200412-405)

        PuTTY是一款免费的Telnet和SSH客户端实现,可使用在Win32平台下。
        PuTTY 0.55之前版本在处理畸形包数据时存在问题,远程攻击者可以利用这个漏洞构建恶意服务器,诱使putty访问,可以用户进程权限在系统上执行任意指令。Core Security小组发现putty存在一个严重问题。允许SSH2服务器在主机KEY验证之前攻击putty客户端。攻击者可以构建恶意SSH服务器,让putty用户连接时触发此漏洞。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:putty:putty:0.54
cpe:/a:putty:putty:0.53
cpe:/a:putty:putty:0.49
cpe:/a:putty:putty:0.48
cpe:/a:putty:putty:0.53b
cpe:/a:putty:putty:0.50
cpe:/a:putty:putty:0.52
cpe:/a:putty:putty:0.51

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1440
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1440
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-405
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109167869528138&w=2
(UNKNOWN)  BUGTRAQ  20040804 CORE-2004-0705: Vulnerabilities in PuTTY and PSCP
http://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html
(UNKNOWN)  CONFIRM  http://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html
http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-modpow.html
(UNKNOWN)  CONFIRM  http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-modpow.html
http://www.gentoo.org/security/en/glsa/glsa-200408-04.xml
(PATCH)  GENTOO  GLSA-200408-04
http://www.securityfocus.com/bid/10850
(PATCH)  BID  10850
http://xforce.iss.net/xforce/xfdb/16885
(UNKNOWN)  XF  putty-code-execution(16885)

- 漏洞信息

PuTTY/PSCP远程任意指令执行漏洞
高危 边界条件错误
2004-12-31 00:00:00 2012-12-07 00:00:00
远程  
        PuTTY是一款免费的Telnet和SSH客户端实现,可使用在Win32平台下。
        PuTTY 0.55之前版本在处理畸形包数据时存在问题,远程攻击者可以利用这个漏洞构建恶意服务器,诱使putty访问,可以用户进程权限在系统上执行任意指令。Core Security小组发现putty存在一个严重问题。允许SSH2服务器在主机KEY验证之前攻击putty客户端。攻击者可以构建恶意SSH服务器,让putty用户连接时触发此漏洞。

- 公告与补丁

        厂商补丁:
        Simon Tatham
        ------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载putty 0.55版本:
        
        http://www.chiark.greenend.org.uk/~sgtatham/putty/

- 漏洞信息

8299
PuTTY modpow() Pre-authentication Arbitrary Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

PuTTy contains a flaw that may allow a malicious user to execute arbitrary code. The issue is triggered when an attacker sends specially crafted packets to a client during authentication. It is possible that the flaw may allow the attacker to compromise and execute arbitrary code resulting in a loss of confidentiality, and integrity.

- 时间线

2004-08-04 Unknow
2004-08-04 2004-08-03

- 解决方案

Upgrade to version 0.55 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站