CVE-2004-1430
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:54:39
NMCO    

[原文]SQL injection vulnerability in the show_stats module in Arcade.php in IbProArcade allows remote attackers to execute arbitrary SQL code via the gameid parameter.


[CNNVD]IBProArcade远程SQL注入漏洞(CNNVD-200412-1051)

        
        IbProArcade是一款流行的论坛程序。
        IbProArcade不正确过滤用户提交的URL参数,远程攻击者可以利用这个漏洞进行SQL注入攻击,获得敏感信息。
        问题是index.php对用户提交'gameid'参数的数据缺少过滤,提交恶意SQL命令作为此值参数,可更改原来的SQL逻辑,可能获得敏感信息或修改数据库。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1430
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1430
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1051
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110451448630711&w=2
(UNKNOWN)  BUGTRAQ  20041231 SQL Injection Vulnerability In IBProArcade
http://www.securityfocus.com/bid/12138
(UNKNOWN)  BID  12138
http://xforce.iss.net/xforce/xfdb/18720
(UNKNOWN)  XF  ibproarcade-gameid-sql-injection(18720)

- 漏洞信息

IBProArcade远程SQL注入漏洞
高危 输入验证
2004-12-31 00:00:00 2006-06-15 00:00:00
远程  
        
        IbProArcade是一款流行的论坛程序。
        IbProArcade不正确过滤用户提交的URL参数,远程攻击者可以利用这个漏洞进行SQL注入攻击,获得敏感信息。
        问题是index.php对用户提交'gameid'参数的数据缺少过滤,提交恶意SQL命令作为此值参数,可更改原来的SQL逻辑,可能获得敏感信息或修改数据库。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 找到如下代码:
        [code] //----------------------------------------
         // Show_Stats
         //
         // This shows the leaderboard
         //
         //----------------------------------------
         function show_stats() {
         global $ibforums, $DB, $std;[/code]
        直接在下面增加:
        [code]if(!is_numeric($ibforums->input['gameid']))
         {
         $std->Error( array( 'LEVEL' => 1, 'MSG' => 'dont_try_it') );
         }[/code]
        然后打开 lang/en/lang_Arcade.php文件,在最后找到如下代码:
        [code] );
        ?>[/code]
        在其上面增加如下代码:
        [code]
        #security
        dont_try_it => "I don't think so annie."[/code]
        厂商补丁:
        ibProArcade
        -----------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.ibproarcade.com/

- 漏洞信息

12807
ibProArcade High Score Module Arcade.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

ibProArcade High Score Module contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'Arcade.php' script not properly sanitizing user-supplied input to the 'gameid' and 'cat' parameter. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2004-12-31 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站