CVE-2004-1424
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:54:31
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in view.php in Moodle 1.4.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the search parameter.


[CNNVD]Moodle多个安全漏洞(CNNVD-200412-936)

        
        Moodle是一款教育相关的管理系统,包括信息的获取、传递、交流。
        Moodle对用户提交的请求缺少充分过滤,远程攻击者可以利用这个漏洞获得敏感信息或查看文件内容。
        问题一是跨站脚本问题:
        '/mod/forum/view.php'对用户提交给'$search'变量数据缺少充分过滤,提交包含恶意HTML代码作为变量数据,可导致敏感信息泄露。
        问题二是会话文件泄露问题:
        所有包含会话数据的文件保存在`moodledata`目录中,本来必须隐藏的,但由于如下代码:
        45> $pathname = "$CFG->dataroot$pathinfo";
        $pathinfo由detect_munged_arguments()函数检查,攻击者可'..'字符来绕过目录限制,查看读取会话数据。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:moodle:moodle:1.3.4Moodle 1.3.4
cpe:/a:moodle:moodle:1.3Moodle 1.3
cpe:/a:moodle:moodle:1.2Moodle 1.2
cpe:/a:moodle:moodle:1.2.1Moodle 1.2.1
cpe:/a:moodle:moodle:1.4.2Moodle 1.4.2
cpe:/a:moodle:moodle:1.3.1Moodle 1.3.1
cpe:/a:moodle:moodle:1.4.1Moodle 1.4.1
cpe:/a:moodle:moodle:1.3.2Moodle 1.3.2
cpe:/a:moodle:moodle:1.3.3Moodle 1.3.3
cpe:/a:moodle:moodle:1.1.1Moodle 1.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1424
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1424
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-936
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110425409614735&w=2
(UNKNOWN)  BUGTRAQ  20041227 Multiple Vulnerabilities in Moodle
http://marc.info/?l=bugtraq&m=110444531816566&w=2
(UNKNOWN)  BUGTRAQ  20041230 Re: Multiple Vulnerabilities in Moodle
http://www.securityfocus.com/bid/12120
(PATCH)  BID  12120
http://xforce.iss.net/xforce/xfdb/18702
(UNKNOWN)  XF  moodle-view-search-xss(18702)

- 漏洞信息

Moodle多个安全漏洞
中危 输入验证
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Moodle是一款教育相关的管理系统,包括信息的获取、传递、交流。
        Moodle对用户提交的请求缺少充分过滤,远程攻击者可以利用这个漏洞获得敏感信息或查看文件内容。
        问题一是跨站脚本问题:
        '/mod/forum/view.php'对用户提交给'$search'变量数据缺少充分过滤,提交包含恶意HTML代码作为变量数据,可导致敏感信息泄露。
        问题二是会话文件泄露问题:
        所有包含会话数据的文件保存在`moodledata`目录中,本来必须隐藏的,但由于如下代码:
        45> $pathname = "$CFG->dataroot$pathinfo";
        $pathinfo由detect_munged_arguments()函数检查,攻击者可'..'字符来绕过目录限制,查看读取会话数据。
        

- 公告与补丁

        厂商补丁:
        Moodle
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://www.moodle.org

- 漏洞信息

12635
Moodle view.php search Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Moodle contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'search' variables upon submission to the 'view.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-12-27 Unknow
2004-12-27 Unknow

- 解决方案

Upgrade to version 1.4.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站