CVE-2004-1423
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:54:30
NMCO    

[原文]Multiple PHP remote file inclusion vulnerabilities in Sean Proctor PHP-Calendar before 0.10.1, as used in Commonwealth of Massachusetts Virtual Law Office (VLO) and other products, allow remote attackers to execute arbitrary PHP code via a URL in the phpc_root_path parameter to (1) includes/calendar.php or (2) includes/setup.php.


[CNNVD]php-Calendar远程任意命令执行漏洞(CNNVD-200412-385)

        
        php-Calendar是一款基于WEB的日历事务系统。
        php-Calendar多个脚本不正确过滤用户提交的参数,远程攻击者可以利用这个漏洞以WEB进程权限执行任意命令。
        php-Calendar包含的'includes/calendar.php'和'includes/setup.php'不正确过滤用户提交给'phpc_root_path'的参数,指定远程恶意服务器上的文件作为参数,可导致以WEB进程权限执行文件中的任意命令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

cpe:/a:php-calendar:php-calendar:0.9PHP-Calendar PHP-Calendar 0.9
cpe:/a:php-calendar:php-calendar:0.8PHP-Calendar PHP-Calendar 0.8
cpe:/a:php-calendar:php-calendar:0.7PHP-Calendar PHP-Calendar 0.7
cpe:/a:php-calendar:php-calendar:0.6PHP-Calendar PHP-Calendar 0.6
cpe:/a:php-calendar:php-calendar:0.5PHP-Calendar PHP-Calendar 0.5
cpe:/a:php-calendar:php-calendar:0.4PHP-Calendar PHP-Calendar 0.4
cpe:/a:php-calendar:php-calendar:0.3PHP-Calendar PHP-Calendar 0.3
cpe:/a:php-calendar:php-calendar:0.2PHP-Calendar PHP-Calendar 0.2
cpe:/a:php-calendar:php-calendar:0.1PHP-Calendar PHP-Calendar 0.1
cpe:/a:php-calendar:php-calendar:0.9.1PHP-Calendar PHP-Calendar 0.9.1
cpe:/a:php-calendar:php-calendar:0.10PHP-Calendar PHP-Calendar 0.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1423
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1423
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-385
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110434580716205&w=2
(UNKNOWN)  BUGTRAQ  20041229 php-Calendar File Include Vulnerability [ Command Exec ]
http://securitytracker.com/id?1017107
(UNKNOWN)  SECTRACK  1017107
http://sourceforge.net/project/shownotes.php?release_id=296020&group_id=46800
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=296020&group_id=46800
http://www.gulftech.org/?node=research&article_id=00060-12292004
(PATCH)  MISC  http://www.gulftech.org/?node=research&article_id=00060-12292004
http://www.milw0rm.com/exploits/2608
(UNKNOWN)  MILW0RM  2608
http://www.securityfocus.com/archive/1/archive/1/449397/100/0/threaded
(UNKNOWN)  BUGTRAQ  20061021 Virtual Law Office (phpc_root_path) Remote File Include Vulnerability
http://www.securityfocus.com/bid/12127
(UNKNOWN)  BID  12127
http://www.securityfocus.com/bid/20657
(UNKNOWN)  BID  20657
http://www.vupen.com/english/advisories/2006/4145
(VENDOR_ADVISORY)  VUPEN  ADV-2006-4145
http://xforce.iss.net/xforce/xfdb/18710
(UNKNOWN)  XF  php-calendar-file-include(18710)
http://xforce.iss.net/xforce/xfdb/29710
(UNKNOWN)  XF  vlo-phpcrootpath-file-include(29710)

- 漏洞信息

php-Calendar远程任意命令执行漏洞
高危 输入验证
2004-12-31 00:00:00 2006-10-30 00:00:00
远程  
        
        php-Calendar是一款基于WEB的日历事务系统。
        php-Calendar多个脚本不正确过滤用户提交的参数,远程攻击者可以利用这个漏洞以WEB进程权限执行任意命令。
        php-Calendar包含的'includes/calendar.php'和'includes/setup.php'不正确过滤用户提交给'phpc_root_path'的参数,指定远程恶意服务器上的文件作为参数,可导致以WEB进程权限执行文件中的任意命令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 把如下代码增加到受影响的脚本中:
        if ( !defined('IN_PHPC') ) {
         die("Hacking attempt");
        }
        厂商补丁:
        PHP-Calendar
        ------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://php-calendar.sourceforge.net/

- 漏洞信息

12700
php-Calendar calendar.php phpc_root_path Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

- 时间线

2004-12-29 Unknow
2004-12-29 Unknow

- 解决方案

Upgrade to version 0.10.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站