CVE-2004-1422
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:54:29
NMCO    

[原文]WHM AutoPilot 2.4.6.5 and earlier allows remote attackers to gain sensitive information via phpinfo, which reveals php settings.


[CNNVD]WHM Autopilot多个安全漏洞(CNNVD-200412-341)

        
        WHM AutoPilot是一款相关的主机管理系统。
        WHM AutoPilot对用户提交的请求缺少充分过滤,远程攻击者可以利用这个漏洞获得敏感信息或查看文件内容,并能以WEB进程执行任意命令。
        问题一是跨站脚本问题:
        /themes/blue/目录下的一些脚本对用户提交的参数缺少充分,提交恶意HTML代码,并诱使用户访问可导致敏感信息泄露。
        问题二是信息泄露问题:
        默认WHM AutoPilot包含phpinfo()脚本,攻击者可以因此获得敏感信息。
        问题三是文件包含:
        'inc'目录中多个脚本如'header.php/step_one.php'、'step_one_tables.php'、'step_two_tables.php'对'server_inc'变量缺少充分过滤,提交包含远程服务器的恶意文件作为包含文件,可导致以WEB进程权限执行恶意文件中的任意命令。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:whm:whm_autopilot:2.4.5
cpe:/a:whm:whm_autopilot:2.4.6
cpe:/a:whm:whm_autopilot:2.4.6.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1422
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1422
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-341
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110425620105529&w=2
(UNKNOWN)  BUGTRAQ  20041228 Multiple WHM Autopilot Vulnerabilities
http://marc.info/?l=bugtraq&m=110451997904494&w=2
(UNKNOWN)  BUGTRAQ  20041231 WHM AutoPilot Security Release [ Plus Upgrade Instructions ]
http://www.gulftech.org/?node=research&article_id=00059-12272004
(UNKNOWN)  MISC  http://www.gulftech.org/?node=research&article_id=00059-12272004
http://www.securityfocus.com/bid/12119
(UNKNOWN)  BID  12119
http://www.whmautopilot.com/forum/lofiversion/index.php/t6785.html
(VENDOR_ADVISORY)  CONFIRM  http://www.whmautopilot.com/forum/lofiversion/index.php/t6785.html
http://xforce.iss.net/xforce/xfdb/18701
(UNKNOWN)  XF  whm-autopilot-information-disclosure(18701)

- 漏洞信息

WHM Autopilot多个安全漏洞
中危 输入验证
2004-12-31 00:00:00 2006-09-22 00:00:00
远程  
        
        WHM AutoPilot是一款相关的主机管理系统。
        WHM AutoPilot对用户提交的请求缺少充分过滤,远程攻击者可以利用这个漏洞获得敏感信息或查看文件内容,并能以WEB进程执行任意命令。
        问题一是跨站脚本问题:
        /themes/blue/目录下的一些脚本对用户提交的参数缺少充分,提交恶意HTML代码,并诱使用户访问可导致敏感信息泄露。
        问题二是信息泄露问题:
        默认WHM AutoPilot包含phpinfo()脚本,攻击者可以因此获得敏感信息。
        问题三是文件包含:
        'inc'目录中多个脚本如'header.php/step_one.php'、'step_one_tables.php'、'step_two_tables.php'对'server_inc'变量缺少充分过滤,提交包含远程服务器的恶意文件作为包含文件,可导致以WEB进程权限执行恶意文件中的任意命令。
        

- 公告与补丁

        厂商补丁:
        WHM
        ---
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.whmautopilot.com/

- 漏洞信息

12697
WHM AutoPilot phpinfo.php Information Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-12-28 Unknow
2004-12-28 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站