CVE-2004-1415
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:54:20
NMCO    

[原文]SQL injection vulnerability in (1) disp_album.php and possibly (2) disp_img.php in 2Bgal 2.4 and 2.5.1 allows remote attackers to execute arbitrary SQL commands via the id_album parameter.


[CNNVD]2BGal远程SQL注入漏洞 (CNNVD-200412-173)

        2Bgal 2.4至2.5.1版本的(1) disp_album.php和可能(2) disp_img.php存在SQL注入漏洞。远程攻击者可以借助id_album参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:ben3w:2bgal:2.4
cpe:/a:ben3w:2bgal:2.5.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1415
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1415
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-173
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110375900916558&w=2
(UNKNOWN)  BUGTRAQ  20041222 2Bgal : 2.4 & 2.5.1 SQL injection Vulnerability
http://www.securityfocus.com/bid/12083
(PATCH)  BID  12083
http://xforce.iss.net/xforce/xfdb/18645
(UNKNOWN)  XF  2bgal-dispalbum-sql-injection(18645)

- 漏洞信息

2BGal远程SQL注入漏洞
中危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        2Bgal 2.4至2.5.1版本的(1) disp_album.php和可能(2) disp_img.php存在SQL注入漏洞。远程攻击者可以借助id_album参数执行任意SQL命令。

- 公告与补丁

        The vendor has released 2BGal 2.5.2 to address this issue.
        2BGal 2BGal 2.5.1
        

- 漏洞信息

12565
2Bgal disp_album.php id_album Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

2Bgal contains a flaw that may allow a malicious user to execute arbitrary code. The issue is triggered when a malicious user submits specially crafted input to the id_album parameter of disp_album.php. It is possible that the flaw may allow manipulation of SQL queries resulting in a loss of integrity.

- 时间线

2004-12-22 Unknow
2004-12-22 Unknow

- 解决方案

Upgrade to version 2.5.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站