发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:54:12

[原文]Multiple cross-site scripting vulnerabilities in Image Gallery Web Application 0.9.10 allow remote attackers to inject arbitrary web script or HTML.

[CNNVD]Singapore Image Gallery多个远程漏洞(CNNVD-200412-614)

        Image Gallery Web应用程序0.9.10版本存在多个跨站脚本漏洞。远程攻击者可以利用该漏洞注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20041216 [SIG^2 G-TEC] singapore Image Gallery Web Application v0.9.10 Multiple Vulnerabilities
(PATCH)  BID  11990

- 漏洞信息

Singapore Image Gallery多个远程漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
        Image Gallery Web应用程序0.9.10版本存在多个跨站脚本漏洞。远程攻击者可以利用该漏洞注入任意web脚本或HTML。

- 公告与补丁

        The vendor has released singapore 0.9.11 beta to address these issues:
        singapore singapore 0.9 a beta
        singapore singapore 0.9 beta
        singapore singapore 0.9.1 beta
        singapore singapore 0.9.10
        singapore singapore 0.9.10 beta
        singapore singapore 0.9.2 beta
        singapore singapore 0.9.3 beta
        singapore singapore 0.9.4 beta
        singapore singapore 0.9.5 beta
        singapore singapore 0.9.6 beta
        singapore singapore 0.9.7 beta
        singapore singapore 0.9.8 beta
        singapore singapore 0.9.9 a beta
        singapore singapore 0.9.9 b beta

- 漏洞信息

singapore Image Gallery index.php image Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

singapore Image Gallery contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'image' variables upon submission to the 'index.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-12-16 2004-11-17
2004-12-16 Unknow

- 解决方案

Upgrade to version 0.9.11 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者