CVE-2004-1399
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:54:00
NMCO    

[原文]Directory traversal vulnerability in the Attachment module 2.3.10 and earlier for phpBB allows remote attackers to read arbitrary files via a .. (dot dot) in the filename.


[CNNVD]Opentools Attachment Mod多个远程漏洞(CNNVD-200412-221)

        phpBB的Attachment module 2.3.10版本及之前版本中存在目录遍历漏洞。远程攻击者可以借助文件名中的..(点 点)读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:opentools:attachment_mod:2.3.7
cpe:/a:opentools:attachment_mod:2.3.4
cpe:/a:opentools:attachment_mod:2.3.10
cpe:/a:opentools:attachment_mod:2.3.9
cpe:/a:opentools:attachment_mod:2.3.6
cpe:/a:opentools:attachment_mod:2.3.5
cpe:/a:opentools:attachment_mod:2.3.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1399
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1399
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-221
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110304269031484&w=2
(UNKNOWN)  BUGTRAQ  20041214 phpBB Attachment Mod Directory Traversal HTTP POST Injection
http://www.securityfocus.com/bid/11893
(PATCH)  BID  11893
http://xforce.iss.net/xforce/xfdb/18437
(UNKNOWN)  XF  attachment-mod-directory-traversal(18437)

- 漏洞信息

Opentools Attachment Mod多个远程漏洞
中危 路径遍历
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        phpBB的Attachment module 2.3.10版本及之前版本中存在目录遍历漏洞。远程攻击者可以借助文件名中的..(点 点)读取任意文件。

- 公告与补丁

        The vendor has released an update to address these issues:
        Opentools Attachment Mod 2.3.10
        
        Opentools Attachment Mod 2.3.4
        
        Opentools Attachment Mod 2.3.5
        
        Opentools Attachment Mod 2.3.6
        
        Opentools Attachment Mod 2.3.7
        
        Opentools Attachment Mod 2.3.8
        
        Opentools Attachment Mod 2.3.9
        

- 漏洞信息

12332
phpBB Attachment Mod Directory Traversal Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpBB Attachment Mod contains a flaw that allows a remote attacker to access files outside of the web path. The issue is due to Attachment Mod not properly sanitizing user input, specifically traversal style attacks (../../) supplied via the "attachment_list[]" and "filename_list[]" variables.

- 时间线

2004-12-14 2004-12-07
2004-12-14 Unknow

- 解决方案

Upgrade to version 2.3.11 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站