CVE-2004-1390
CVSS10.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:41:14
NMCO    

[原文]Multiple buffer overflows in the PPPoE daemon (PPPoEd) in QNX RTP 6.1 allow remote attackers to execute arbitrary code via a long argument to the (1) -F, (2) name, (3) en, (4) upscript, (5) downscript, (6) retries, (7) timeout, (8) scriptdetach, (9) noscript, (10) nodetach, (11) remote_mac, or (12) local_mac flags.


[CNNVD]QNX PPPoEd多个本地缓冲区溢出漏洞(CNNVD-200412-1031)

        QNX RTP 6.1版本的PPPoE守护程序(PPPoEd)存在多个缓冲区溢出漏洞。远程攻击者借助(1)-F,(2)name,(3)en,(4)upscript,(5)downscript,(6)retries, (7)timeout,(8)scriptdetach,(9)noscript,(10)nodetach,(11)remote_mac,或者(12) local_mac的超长参数执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:qnx:rtos:4.25
cpe:/a:qnx:rtp:6.1
cpe:/a:qnx:rtos:6.2.0
cpe:/a:qnx:rtos:2.4
cpe:/a:qnx:rtos:6.2.0a
cpe:/a:qnx:rtos:6.1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1390
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1390
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1031
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/961686
(VENDOR_ADVISORY)  CERT-VN  VU#961686
http://xforce.iss.net/xforce/xfdb/17280
(UNKNOWN)  XF  Qnx-rtp-pppoed-flags-bo(17280)
http://www.securityfocus.com/bid/11104
(UNKNOWN)  BID  11104
http://archives.neohapsis.com/archives/fulldisclosure/2004-09/0155.html
(UNKNOWN)  FULLDISC  20040903 [RLSA_01-2004] QNX PPPoEd local root vulnerabilities

- 漏洞信息

QNX PPPoEd多个本地缓冲区溢出漏洞
危急 缓冲区溢出
2004-12-31 00:00:00 2005-10-20 00:00:00
本地  
        QNX RTP 6.1版本的PPPoE守护程序(PPPoEd)存在多个缓冲区溢出漏洞。远程攻击者借助(1)-F,(2)name,(3)en,(4)upscript,(5)downscript,(6)retries, (7)timeout,(8)scriptdetach,(9)noscript,(10)nodetach,(11)remote_mac,或者(12) local_mac的超长参数执行任意代码。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息

9660
QNX PPPoEd Multiple Option Local Overflows
Local Access Required Input Manipulation
Loss of Integrity

- 漏洞描述

A LOCAL overflow exists in QNX PPPoEd. PPPoEd fails to validate a number of command line options resulting in a core dump. With a specially crafted request, an attacker can overwrite memory and escalate priveleges resulting in a loss of integrity.

- 时间线

2004-09-02 2004-08-27
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue. It is possible to restrict untrusted users from executing pppoed.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站