CVE-2004-1387
CVSS2.1
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-10 15:30:05
NMCO    

[原文]The check_forensic script in apache-utils package 1.3.31 allows local users to overwrite or create arbitrary files via a symlink attack on temporary files.


[CNNVD]apache-utils package check_forensic脚本覆盖或者创建任意文件漏洞(CNNVD-200412-982)

        apache-utils package 1.3.31 版本的check_forensic脚本存在漏洞。本地用户借助临时文件中的符号链接攻击覆盖或者创建任意文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1387
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1387
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-982
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/18993
(UNKNOWN)  XF  apache-checkforensic-symlink(18993)
http://secunia.com/advisories/13925
(UNKNOWN)  SECUNIA  13925
http://www.ubuntulinux.org/support/documentation/usn/usn-65-1
(UNKNOWN)  UBUNTU  USN-65-1
http://lists.debian.org/debian-apache/2005/01/msg00076.html
(UNKNOWN)  MLIST  [debian-apache] 20050119 Bug#290974: marked as done (apache: Temporary usage bugs that can be used in symlink attacks)

- 漏洞信息

apache-utils package check_forensic脚本覆盖或者创建任意文件漏洞
低危 未知
2004-12-31 00:00:00 2005-10-20 00:00:00
本地  
        apache-utils package 1.3.31 版本的check_forensic脚本存在漏洞。本地用户借助临时文件中的符号链接攻击覆盖或者创建任意文件。

- 公告与补丁

        

- 漏洞信息

13087
Apache HTTP Server mod_log_forensic check_forensic Symlink Arbitrary File Creation / Overwrite
Local Access Required Race Condition
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Apache contains a flaw that may allow a malicious local user to corrupt, write to or create arbitrary files with the privileges of the user or process running the vulnerable script. The issue is triggered when 'check_forensic' script is activated. It is possible that the flaw may allow a loss of integrity.

- 时间线

2005-01-20 Unknow
2005-01-18 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Ubuntu Linix has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站