CVE-2004-1384
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:53:50
NMCOE    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in phpGroupWare 0.9.16.003 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) kp3, (2) type, (3) msg, (4) forum_id, (5) pos, (6) cats_app, (7) cat_id, (8) msgball[msgnum], (9) fldball[acctnum] parameters to index.php or (10) ticket_id to viewticket_details.php.


[CNNVD]PHPGroupWare多个跨站脚本和SQL注入漏洞(CNNVD-200412-739)

        phpGroupWare 0.9.16.003及其以前的的版本存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)kp3,(2)type,(3)msg, (4 forum_id,(5)pos,(6)cats_app,(7)cat_id, (8)msgball[msgnum],(9)index.php的fldball[acctnum]参数或者 (10)viewticket_details.php的ticket_id注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpgroupware:phpgroupware:0.9.12
cpe:/a:phpgroupware:phpgroupware:0.9.14.005
cpe:/a:phpgroupware:phpgroupware:0.9.13
cpe:/a:phpgroupware:phpgroupware:0.9.14
cpe:/a:phpgroupware:phpgroupware:0.9.14.007
cpe:/a:phpgroupware:phpgroupware:0.9.14.006
cpe:/a:phpgroupware:phpgroupware:0.9.16.000
cpe:/a:phpgroupware:phpgroupware:0.9.16.003
cpe:/a:phpgroupware:phpgroupware:0.9.16.002
cpe:/a:phpgroupware:phpgroupware:0.9.14.003
cpe:/a:phpgroupware:phpgroupware:0.9.16_rc1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1384
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1384
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-739
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110312656029072&w=2
(UNKNOWN)  BUGTRAQ  20041215 Multiple phpGroupWare Vulnerabilities [ phpGroupWare 0.9.16.003 && Earlier ]
http://www.gentoo.org/security/en/glsa/glsa-200501-08.xml
(PATCH)  GENTOO  GLSA-200501-08
http://www.gulftech.org/?node=research&article_id=00054-12142004
(UNKNOWN)  MISC  http://www.gulftech.org/?node=research&article_id=00054-12142004
http://www.securityfocus.com/bid/11952
(PATCH)  BID  11952
http://xforce.iss.net/xforce/xfdb/18496
(UNKNOWN)  XF  phpgroupware-index-preferences-xss(18496)

- 漏洞信息

PHPGroupWare多个跨站脚本和SQL注入漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        phpGroupWare 0.9.16.003及其以前的的版本存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)kp3,(2)type,(3)msg, (4 forum_id,(5)pos,(6)cats_app,(7)cat_id, (8)msgball[msgnum],(9)index.php的fldball[acctnum]参数或者 (10)viewticket_details.php的ticket_id注入任意web脚本或者HTML。

- 公告与补丁

        Gentoo has released an advisory to provide updates for this issue. Updates may be applied by running the following commands as the superuser:
        emerge --sync
        emerge --ask --oneshot --verbose ">=www-apps/phpgroupware-0.9.16.004"
        The vendor has addressed these issues in PHPGroupWare 0.9.16.005.
        PHPGroupWare PHPGroupWare 0.9.12
        
        PHPGroupWare PHPGroupWare 0.9.13
        
        PHPGroupWare PHPGroupWare 0.9.14 .006
        
        PHPGroupWare PHPGroupWare 0.9.14 .005
        
        PHPGroupWare PHPGroupWare 0.9.14 .003
        
        PHPGroupWare PHPGroupWare 0.9.14 .007
        
        PHPGroupWare PHPGroupWare 0.9.16 RC1
        
        PHPGroupWare PHPGroupWare 0.9.16 .000
        
        PHPGroupWare PHPGroupWare 0.9.16 .003
        
        PHPGroupWare PHPGroupWare 0.9.16 .002
        

- 漏洞信息 (24844)

phpGroupWare 0.9.x index.php Multiple Parameter XSS (EDBID:24844)
php webapps
2004-12-15 Verified
0 James Bercegay
N/A [点击下载]
source: http://www.securityfocus.com/bid/11952/info

Reportedly PHPGroupWare contains multiple input validation vulnerabilities; it is prone to multiple SQL injection and cross-site scripting issues. These issues are all due to a failure of the application to properly sanitize user-supplied input. 

The SQL injection issues may allow a remote attacker to manipulate query logic, potentially leading to unauthorized access to sensitive information such as the administrator password hash or corruption of database data. SQL injection attacks may also potentially be used to exploit latent vulnerabilities in the underlying database implementation. 

The cross-site scripting issues could permit a remote attacker to create a malicious link to the vulnerable application that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks. 

These issues were identified in PHPGroupWare 0.9.16.003, however, it is possible that other versions are affected as well.

http://www.example.com/phpgroupware/wiki/index.php?kp3=99884d8a63791f406585913d74476b11
%22%3E%3Ciframe%3E
http://www.example.com/phpgroupware/index.php?menuaction=forum.uiforum.post&type=new%22
%3E%3Ciframe%3E
http://www.example.com/phpgroupware/index.php?menuaction=forum.uiforum.read&msg=202%22%
3E%3Ciframe%3E
http://www.example.com/phpgroupware/index.php?menuaction=forum.uiforum.read&forum_id=3%
22%3E%3Ciframe%3E&msg=202
http://www.example.com/phpgroupware/index.php?menuaction=forum.uiforum.read&msg=42&pos=
10%22%3E%3Ciframe%3E
http://www.example.com/phpgroupware/index.php?menuaction=preferences.uicategories.index
&cats_app=%22%3E%3Ciframe%3E
http://www.example.com/phpgroupware/index.php?menuaction=preferences.uicategories.edit&
cats_app=notes&extra=&global_cats=True&cats_level=True&cat_parent=188&cat_id
=188%22%3E%3Ciframe%3E
http://www.example.com/phpgroupware/index.php?menuaction=email.uimessage.message&msgbal
l[msgnum]=1%22%3E%3Ciframe%3E&msgball[folder]=INBOX.hello&msgball[acctnum]=0
&sort=1&order=1&start=0
http://www.example.com/phpgroupware/index.php?menuaction=email.uicompose.compose&fldbal
l[folder]=INBOX.hello&fldball[acctnum]=0&to=%22%3E%3Ciframe%3E&personal=&sor
t=1&order=1&start=0		

- 漏洞信息 (24845)

phpGroupWare 0.9.x viewticket_details.php ticket_id Parameter XSS (EDBID:24845)
php webapps
2004-12-15 Verified
0 James Bercegay
N/A [点击下载]
source: http://www.securityfocus.com/bid/11952/info
 
Reportedly PHPGroupWare contains multiple input validation vulnerabilities; it is prone to multiple SQL injection and cross-site scripting issues. These issues are all due to a failure of the application to properly sanitize user-supplied input.
 
The SQL injection issues may allow a remote attacker to manipulate query logic, potentially leading to unauthorized access to sensitive information such as the administrator password hash or corruption of database data. SQL injection attacks may also potentially be used to exploit latent vulnerabilities in the underlying database implementation.
 
The cross-site scripting issues could permit a remote attacker to create a malicious link to the vulnerable application that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.
 
These issues were identified in PHPGroupWare 0.9.16.003, however, it is possible that other versions are affected as well.

http://www.example.com/phpgroupware/tts/viewticket_details.php?ticket_id=338%22%3E%3Cif
rame%3E		

- 漏洞信息

12393
phpGroupWare index.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpGroupWare contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate multiple variables upon submission to the 'index.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-12-14 Unknow
2004-12-14 Unknow

- 解决方案

Upgrade to version 0.9.16.004 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站