CVE-2004-1383
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:53:49
NMCOE    

[原文]Multiple SQL injection vulnerabilities in phpGroupWare 0.9.16.003 and earlier allow remote attackers to execute arbitrary SQL statements via the (1) order, (2) project_id, (3) pro_main, or (4) hours_id parameters to index.php or (5) ticket_id to viewticket_details.php.


[CNNVD]PHPGroupWare多个跨站脚本和SQL注入漏洞(CNNVD-200412-1210)

        phpGroupWare 0.9.16.003及其早期版本存在多个SQL注入漏洞。远程攻击者可以通过(1)命令,(2)project_id,(3)pro_main,或(4)index.php的hours_id参数或(5)viewticket_details.php的ticket_id参数执行任意SQL语句。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpgroupware:phpgroupware:0.9.12
cpe:/a:phpgroupware:phpgroupware:0.9.14.005
cpe:/a:phpgroupware:phpgroupware:0.9.13
cpe:/a:phpgroupware:phpgroupware:0.9.14
cpe:/a:phpgroupware:phpgroupware:0.9.14.007
cpe:/a:phpgroupware:phpgroupware:0.9.14.006
cpe:/a:phpgroupware:phpgroupware:0.9.16.000
cpe:/a:phpgroupware:phpgroupware:0.9.16.003
cpe:/a:phpgroupware:phpgroupware:0.9.16.002
cpe:/a:phpgroupware:phpgroupware:0.9.14.003
cpe:/a:phpgroupware:phpgroupware:0.9.16_rc1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1383
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1383
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1210
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110312656029072&w=2
(UNKNOWN)  BUGTRAQ  20041215 Multiple phpGroupWare Vulnerabilities [ phpGroupWare 0.9.16.003 && Earlier ]
http://www.gentoo.org/security/en/glsa/glsa-200501-08.xml
(PATCH)  GENTOO  GLSA-200501-08
http://www.gulftech.org/?node=research&article_id=00054-12142004
(UNKNOWN)  MISC  http://www.gulftech.org/?node=research&article_id=00054-12142004
http://www.securityfocus.com/bid/11952
(PATCH)  BID  11952
http://xforce.iss.net/xforce/xfdb/18498
(UNKNOWN)  XF  phpgroupware-projectid-sql-injection(18498)

- 漏洞信息

PHPGroupWare多个跨站脚本和SQL注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        phpGroupWare 0.9.16.003及其早期版本存在多个SQL注入漏洞。远程攻击者可以通过(1)命令,(2)project_id,(3)pro_main,或(4)index.php的hours_id参数或(5)viewticket_details.php的ticket_id参数执行任意SQL语句。

- 公告与补丁

        Gentoo has released an advisory to provide updates for this issue. Updates may be applied by running the following commands as the superuser:
        emerge --sync
        emerge --ask --oneshot --verbose ">=www-apps/phpgroupware-0.9.16.004"
        The vendor has addressed these issues in PHPGroupWare 0.9.16.005.
        PHPGroupWare PHPGroupWare 0.9.12
        
        PHPGroupWare PHPGroupWare 0.9.13
        
        PHPGroupWare PHPGroupWare 0.9.14 .006
        
        PHPGroupWare PHPGroupWare 0.9.14 .005
        
        PHPGroupWare PHPGroupWare 0.9.14 .003
        
        PHPGroupWare PHPGroupWare 0.9.14 .007
        
        PHPGroupWare PHPGroupWare 0.9.16 RC1
        
        PHPGroupWare PHPGroupWare 0.9.16 .000
        
        PHPGroupWare PHPGroupWare 0.9.16 .003
        
        PHPGroupWare PHPGroupWare 0.9.16 .002
        

- 漏洞信息 (24846)

phpGroupWare 0.9.x viewticket_details.php ticket_id Parameter SQL Injection (EDBID:24846)
php webapps
2004-12-15 Verified
0 James Bercegay
N/A [点击下载]
source: http://www.securityfocus.com/bid/11952/info
 
Reportedly PHPGroupWare contains multiple input validation vulnerabilities; it is prone to multiple SQL injection and cross-site scripting issues. These issues are all due to a failure of the application to properly sanitize user-supplied input.
 
The SQL injection issues may allow a remote attacker to manipulate query logic, potentially leading to unauthorized access to sensitive information such as the administrator password hash or corruption of database data. SQL injection attacks may also potentially be used to exploit latent vulnerabilities in the underlying database implementation.
 
The cross-site scripting issues could permit a remote attacker to create a malicious link to the vulnerable application that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.
 
These issues were identified in PHPGroupWare 0.9.16.003, however, it is possible that other versions are affected as well.


http://www.example.com/phpgroupware/tts/viewticket_details.php?ticket_id=355[SQL_QUERY]		

- 漏洞信息

12395
phpGroupWare viewticket_details.php ticket_id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

phpGroupWare contains a flaw that will allow a remote attacker to inject arbitrary SQL code. The problem is that the 'ticket_id' parameter in the 'viewticket_details.php' script is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-12-14 Unknow
2004-12-14 Unknow

- 解决方案

Upgrade to version 0.9.16.004 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站