CVE-2004-1378
CVSS5.0
发布时间 :2004-09-21 00:00:00
修订时间 :2016-10-17 22:53:46
NMCO    

[原文]The expat XML parser code, as used in the open source Jabber (jabberd) 1.4.3 and earlier, jadc2s 0.9.0 and earlier, and possibly other packages, allows remote attackers to cause a denial of service (application crash) via a malformed packet to a socket that accepts XML connections.


[CNNVD]Jabber Studio JabberD远程服务拒绝漏洞(CNNVD-200409-056)

        开放源码Jabber (jabberd)1.4.3及其早期版本,jadc2s 0.9.0及其更早期版本和可能其它数据包中的expat XML解析代码存在漏洞。远程攻击者可以借助socket畸形数据包接收XML连接,导致服务拒绝(应用程序崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:jabberstudio:jabberd:1.4
cpe:/a:jabberstudio:jabberd:1.4.2a
cpe:/a:jabberstudio:jabberd:1.4.3
cpe:/a:jabberstudio:jadc2s:0.7
cpe:/a:jabberstudio:jadc2s:0.9
cpe:/a:jabberstudio:jadc2s:0.6
cpe:/a:jabberstudio:jabberd:1.4.2
cpe:/a:jabberstudio:jabberd:1.4.1
cpe:/a:jabberstudio:jadc2s:0.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1378
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1378
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200409-056
(官方数据源) CNNVD

- 其它链接及资源

http://devel.amessage.info/jabberd14/
(PATCH)  CONFIRM  http://devel.amessage.info/jabberd14/
http://mail.jabber.org/pipermail/jabberd/2004-September/002004.html
(UNKNOWN)  MLIST  [jabberd] 20040919 Jabberd 1.4 critical bug
http://marc.info/?l=bugtraq&m=109583829122679&w=2
(UNKNOWN)  BUGTRAQ  20040920 Possible DoS attack against jabberd 1.4.3 and jadc2s 0.9.0
http://securitytracker.com/id?1011383
(UNKNOWN)  SECTRACK  1011383
http://securitytracker.com/id?1011384
(UNKNOWN)  SECTRACK  1011384
http://www.gentoo.org/security/en/glsa/glsa-200409-31.xml
(PATCH)  GENTOO  GLSA-200409-31
http://www.securityfocus.com/bid/11231
(PATCH)  BID  11231
http://www.vuxml.org/freebsd/2e25d38b-54d1-11d9-b612-000c6e8f12ef.html
(UNKNOWN)  CONFIRM  http://www.vuxml.org/freebsd/2e25d38b-54d1-11d9-b612-000c6e8f12ef.html
http://xforce.iss.net/xforce/xfdb/17466
(PATCH)  XF  jabberd-xml-dos(17466)
http://xforce.iss.net/xforce/xfdb/17467
(UNKNOWN)  XF  jadc2s-xml-dos(17467)

- 漏洞信息

Jabber Studio JabberD远程服务拒绝漏洞
中危 其他
2004-09-21 00:00:00 2005-10-20 00:00:00
远程  
        开放源码Jabber (jabberd)1.4.3及其早期版本,jadc2s 0.9.0及其更早期版本和可能其它数据包中的expat XML解析代码存在漏洞。远程攻击者可以借助socket畸形数据包接收XML连接,导致服务拒绝(应用程序崩溃)。

- 公告与补丁

        It has been reported that this issue has been resolved in the CVS version of the software, although this has not been confirmed.
        Gentoo Linux has released an advisory (GLSA 200409-31). Gentoo has advised that all jabberd users should upgrade to the latest version:
        # emerge sync
        # emerge -pv ">=net-im/jabberd-1.4.3-r4"
         # emerge ">=net-im/jabberd-1.4.3-r4"
        For more information please see the referenced Gentoo advisory.

- 漏洞信息

10257
Multiple Jabber Client Malformed Byte Sequence DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Public Vendor Verified

- 漏洞描述

jabberd and jadc2s contains a flaw that may allow a remote denial of service. The issue is triggered due to the parsing of XML messages. By sending a malformed byte sequence of 0xEF, 0xBB, 0xBF to certain sockets, a remote attacker could cause the application to crash, resulting in a loss of availability.

- 时间线

2004-09-19 Unknow
2004-09-19 Unknow

- 解决方案

Contact your vendor for an appropriate upgrade. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站