CVE-2004-1343
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:41:03
NMCOS    

[原文]CVS 1.12 and earlier on Debian GNU/Linux does not properly handle when a mapping for the current repository does not exist in the cvs-repouids file, which allows remote attackers to cause a denial of service (server crash).


[CNNVD]Debian CVS-Repouid服务拒绝漏洞(CNNVD-200412-1040)

        当一个当前库中的映射不存在于CVS - repouids文件中时,
        Debian GNU/Linux中的CVS 1.12及其以前的版本不能正确的处理,远程攻击者利用该漏洞导致服务拒绝(服务崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:cvs:cvs:1.12
cpe:/a:cvs:cvs:1.11.1_p1
cpe:/a:cvs:cvs:1.11.11
cpe:/a:cvs:cvs:1.11.14
cpe:/a:cvs:cvs:1.11
cpe:/a:cvs:cvs:1.11.10
cpe:/a:cvs:cvs:1.11.2
cpe:/a:cvs:cvs:1.11.4
cpe:/a:cvs:cvs:1.11.16
cpe:/a:cvs:cvs:1.10
cpe:/a:cvs:cvs:1.11.6
cpe:/a:cvs:cvs:1.11.15
cpe:/a:cvs:cvs:1.10.6
cpe:/a:cvs:cvs:1.10.8
cpe:/a:cvs:cvs:1.10.7
cpe:/a:cvs:cvs:1.11.5
cpe:/a:cvs:cvs:1.11.1
cpe:/a:cvs:cvs:1.11.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1343
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1343
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1040
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2005/dsa-715
(VENDOR_ADVISORY)  DEBIAN  DSA-715

- 漏洞信息

Debian CVS-Repouid服务拒绝漏洞
中危 授权问题
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        当一个当前库中的映射不存在于CVS - repouids文件中时,
        Debian GNU/Linux中的CVS 1.12及其以前的版本不能正确的处理,远程攻击者利用该漏洞导致服务拒绝(服务崩溃)。

- 公告与补丁

        Debian has released advisory DSA 715-1 along with fixes addressing this issue. Please see the referenced advisory for more information.

- 漏洞信息

15888
Debian CVS cvs-repouids File Mapping Issue DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Public

- 漏洞描述

Debian CVS contains a flaw that may allow a remote denial of service. The issue is triggered when a cvs-repouids file is created without creating a mapping to a repository, causing the CVS server to crash and resulting in loss of availability.

- 时间线

2005-04-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.11.1p1debian-10 or higher for stable version or version 1.12.9-11 or higher for unstable, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Debian CVS-Repouid Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 13403
Yes No
2005-04-27 12:00:00 2009-07-12 02:06:00
Alberto Garcia is credited with the discovery of this issue.

- 受影响的程序版本

Debian CVS 1.11.1 p1
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 漏洞讨论

A denial of service vulnerability affects Debian CVS. This issue is due to an error with Debian's CVS cvs-repouid patch.

A remote attacker may leverage this issue to cause the CVS process to crash, effectively denying service to legitimate users.

- 漏洞利用

No exploit is required to leveragee this issue.

- 解决方案

Debian has released advisory DSA 715-1 along with fixes addressing this issue. Please see the referenced advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站