CVE-2004-1341
CVSS4.3
发布时间 :2005-04-19 00:00:00
修订时间 :2008-09-05 16:41:03
NMCOPS    

[原文]Cross-site scripting (XSS) vulnerability in info2www before 1.2.2.9 allows remote attackers to inject arbitrary web script or HTML via the arguments to info2www.


[CNNVD]Info2www跨站脚本攻击漏洞(CNNVD-200504-076)

        Info2www是GNU信息结点和WEB服务间的CGI网关,它使得CGI构建于GNU信息结点的所有信息可以兼容HTTP/1.0及以后的服务器网关。
        info2www的1.2.2.9之前版本存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过传给info2www的参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1341
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1341
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200504-076
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/20179
(VENDOR_ADVISORY)  XF  info2www-url-xss(20179)
http://www.debian.org/security/2005/dsa-711
(VENDOR_ADVISORY)  DEBIAN  DSA-711

- 漏洞信息

Info2www跨站脚本攻击漏洞
中危 跨站脚本
2005-04-19 00:00:00 2005-10-20 00:00:00
远程  
        Info2www是GNU信息结点和WEB服务间的CGI网关,它使得CGI构建于GNU信息结点的所有信息可以兼容HTTP/1.0及以后的服务器网关。
        info2www的1.2.2.9之前版本存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过传给info2www的参数注入任意web脚本或HTML。

- 公告与补丁

        
        

- 漏洞信息 (F37781)

dsa-711.txt (PacketStormID:F37781)
2005-06-01 00:00:00
 
advisory,web,arbitrary,xss
linux,debian
CVE-2004-1341
[点击下载]

Debian Security Advisory DSA 711-1 - Nicolas Gregoire discovered a cross-site scripting vulnerability in info2www, a converter for info files to HTML. A malicious person could place a harmless looking link on the web that could cause arbitrary commands to be executed in the browser of the victim user.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 711-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
April 19th, 2005                        http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : info2www
Vulnerability  : missing input sanitising
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-1341
Debian Bug     : 281655

Nicolas Gregoire discovered a cross-site scripting vulnerability in
info2www, a converter for info files to HTML.  A malicious person
could place a harmless looking link on the web that could cause
arbitrary commands to be executed in the browser of the victim user.

For the stable distribution (woody) this problem has been fixed in
version 1.2.2.9-20woody1.

For the unstable distribution (sid) this problem has been fixed in
version 1.2.2.9-23.

We recommend that you upgrade your info2www package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/i/info2www/info2www_1.2.2.9-20woody1.dsc
      Size/MD5 checksum:      600 68a3d62f9ff13abaf1cd2b2ca479c8e9
    http://security.debian.org/pool/updates/main/i/info2www/info2www_1.2.2.9-20woody1.diff.gz
      Size/MD5 checksum:    27216 d4bf5b04bfcaa304bbe18969346a281e
    http://security.debian.org/pool/updates/main/i/info2www/info2www_1.2.2.9.orig.tar.gz
      Size/MD5 checksum:    12407 2d79050502b938fae36d6d38e1d5084b

  Architecture independent components:

    http://security.debian.org/pool/updates/main/i/info2www/info2www_1.2.2.9-20woody1_all.deb
      Size/MD5 checksum:    34006 93914a2ed64150b8682e8e419f7878ed


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)

iD8DBQFCZNrhW5ql+IAeqTIRAm5YAJ9bX20RqmuEO4JdxHYQ9NUxQ1OPIwCghpmp
eZNcGRmjjb/CfGLc93hSfX8=
=QUPE
-----END PGP SIGNATURE-----

    

- 漏洞信息

15673
info2www Argument XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

info2www contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate arguments upon submission to the info2www script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of confidentiality.

- 时间线

2005-04-19 2004-11-17
2004-11-17 Unknow

- 解决方案

Upgrade to version 1.2.2.9-23 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Info2www Cross-Site Scripting Vulnerability
Input Validation Error 13252
Yes No
2005-04-19 12:00:00 2009-07-12 02:06:00
Discovered by Nicolas Gregoire.

- 受影响的程序版本

Roar Smith info2www 1.2.2 .9
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 漏洞讨论

Info2www is prone to a cross-site scripting vulnerability. This could allow an attacker to place a link that appears safe on a Web page but that will in fact cause script code to be executed in a user's browser.

- 漏洞利用

An exploit is not required.

- 解决方案

Debian has released advisory DSA 711-1 and fixes to address this issue:


Roar Smith info2www 1.2.2 .9

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站